Hot Rod Forum : Hotrodders Bulletin Board - Reply to Topic
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Engine> help with smoke
User Name
Password
lost password?   |   register now

Thread: help with smoke Reply to Thread
Title:
  
Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
01-25-2005 08:25 PM
RdNckMike thx for the tip bud, so PCV vales do have specs..? i just picked one off the shelf at discount that fit in the valve cover. i know the Machinist only shaved a little off the heads to freshen them up, ill look into it anyway. thx alot
01-25-2005 08:14 PM
BOBCRMAN@aol.com Check for wrong spec PCV also check for oil leaking into intake runners from the bottom side. Common problem if heads/block have been milled excessively. Sometimes leaving the end seals out (use silicone) and using thicker intake gaskets will cure the problem.
01-25-2005 08:08 PM
RdNckMike
help with smoke

I bought a early 80’s chev 350 out of a ¾ ton van, to have rebuilt and dropped in my k10. I had the crank turned, block 30 over w/flat tops & Hasting rings, mild cam, new lifts & push rods. Total overhaul on heads, with larger intake valves and guides. New Performer intake toped with a used edelbrock 600 that I had rebuilt, and a new Mallory hei dist. Now for the problem….it smokes and burns oil and its well past its brake in. Is it possible that my pcv valve could be pulling oil into the carb? the pcv is new and I know my edelbrock valve covers have baffles. The spark plugs also look fine and the motor runs great.

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -6. The time now is 07:07 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.