Hot Rod Forum : Hotrodders Bulletin Board - Reply to Topic
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Electrical> '96 Chevy Truck - no low beams
User Name
Password
lost password?   |   register now

Thread: '96 Chevy Truck - no low beams Reply to Thread
Title:
  
Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
02-14-2005 12:37 PM
WakBordr7387 Hey I'm right on the other side of the lake from you, Im actuallly in Lakeside City. Good luck on finding the problem, There is a shop that Ive heard of down kemp that deals with electrical work. Its supposedly run by some old guy but does great work I can't think of what its called right now.
02-14-2005 10:28 AM
56Thunder Thanks all - I had a good extended weekend. Wak - I live over by JC park, off of Fairway. Kev, the smell did come from inside the cab and my criuse/blinker switch still works. Is that the switch you are talking about or is there another one down on the column? I'm sure you all are right about how easy it should be to fix, it's just finding the damn thing. I can't find anything visually wrong and I'm not too expierenced on chasing down wires that are connected to something that I have no idea what it is or does. It's probably a lot simpler that I'm making it out to be but, I guess I'm going to make a few phone calls and see if anyone has had any expierence with this. Thanks again.

Robby
02-11-2005 02:33 PM
Kevin45 Sounds like th eswitch in th ecolumn went bad, which from what I hear more and more is characteristic of the Chevys. Does the cruise control still work? And was the smell inside the cab or under the hood? Call your local mechanic or call the Chevy dealer and ask them if this happens quite a bit.

Kevin
02-11-2005 12:20 PM
WakBordr7387 Just follow through all the wires useing a test light/multimeter until you find the problem. like willys said its probably a light switch. When you find it, It shouldn't be that hard of a fix.
BTW, where in wichita falls are you? Ive heard of a place in town that does electrical work like that if you can't figure it out. I can't think of the name at the moment, but Im sure I could find out.
02-11-2005 11:09 AM
willys36@aol.com Sounds like a fried light switch. If it were a shorted wire, you would have blown a fuse. And you are correct, I would rather have a beating with a claw hammer than have to sort out electrical troubles.
02-11-2005 02:35 AM
56Thunder
'96 Chevy Truck - no low beams

Hello all - OK here's my problem. I was driving the other night and smelt something shorting out. I turned on the brights and pulled over to check under the dash and under the hood. Everything looked OK and the smell went away. However, when I pulled away and went to turn my brights off, I had no headlights. So now I can have the brights on or nothing - this is when I pull the blinker switch back and forth from dims to high and with the light switch turned all the way (all of my blinker lights will stay on.) My low beams will come on only when I have the light switch turned half way - set for the running lights. I hope it is something simple, a switch or something that is repacable, but I'm just not sure where to begin. Thanks for any help or advice - sorting through this electric stuff stinks.

Robby

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -6. The time now is 08:09 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.