Hot Rod Forum : Hotrodders Bulletin Board - Reply to Topic
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Transmission - Rearend> T56 transmission
User Name
Password
lost password?   |   register now

Thread: T56 transmission Reply to Thread
Title:
  
Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
05-01-2002 08:05 AM
sixonthefloor McLeod will have their own bellhousing out in about 4 months that will help you out. I just spoke to them last week about that. Sounds like a great product.

Or you can switch to the LT1 style front cover and input shaft for the T56 - the parts are about $300. If you use the LT1 input shaft you'll need an LT1 hydraulic pull clutch and bellhousing, as the LT1 has a slim clutch and correspondingly short input shaft.

Or you could use the "aftermarket" input shaft along with the LT1 front cover and adapter plate. The aftermarket input shaft is longer than the LT1 shaft and along with the aftermarket adapter plate, allows you to use a T5 bellhousing and standard clutch, hydraulic or mechanical.

HTH!

Josh
04-19-2002 10:01 AM
chevypu
T56 transmission

I have a T56 trans out of a 99 Camaro LS1. Didnt know it but the LS1 crank is shorter that earlier gen, and I am told by many that this trans will only work with and LS1 engine. I understand Bob Weir in Napa CA makes an adapter kit, but its $600+. Anyone know how to use this trans with an earlier gen cast iron 350?

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -6. The time now is 07:07 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.