Hot Rod Forum : Hotrodders Bulletin Board - Reply to Topic
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Transmission - Rearend> torq converter
User Name
Password
lost password?   |   register now

Thread: torq converter Reply to Thread
Title:
  
Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
08-02-2002 01:52 PM
78 monte A stahl converter is loose for launch.To allow the motor to get into its power band on take off.I
Sounds like you tranny is slipping.Is you fluid low??Is it a brownish orange w/ a funky burn't smell??I'd say drop the pan change filter and fluid clean pan really good and put in a magnet.Also check your tranny lines for kinks or if ther touching headers or something.
07-31-2002 05:49 PM
dmorris1200 sounds like the trans slipping, may sound silly but did you check the fluid
07-31-2002 07:19 AM
1969cutlass
torq converter

i just made some power on my olds 350 in my 69 cutlass with a carb and intake swap but after about 3/4 open throttle the RPMs rise like it should but i dont go any where! Is my stall speed not enough for the 330 hp? or should i just get my tranny rebuilt

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -6. The time now is 12:19 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.