Hot Rod Forum : Hotrodders Bulletin Board - Reply to Topic
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Transmission - Rearend> 1994 Saturn Transmision Problem
User Name
Password
lost password?   |   register now

Thread: 1994 Saturn Transmision Problem Reply to Thread
Title:
  
Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
01-18-2006 07:59 PM
xk8
Saturn transaxle problem

I just bought a 93 Saturn SC2 for a $100 bucks. It has a transaxle problem when you put it in reverse or drive it won't move but first second and third are ok, but if you just pull back the shifter about 1/16 inch when its in drive or reverse it will drop into gear and go. I checked the adjustment for the park neutral switch and shifter cable all ok. My research on the web tell me that valve body gets iron deposits in it and thats what causes the problem. I ordered a transaxle TAAT manual to disassemble the valve body to clean and repair it.
03-19-2003 09:03 AM
yellowbird Does it just do it going into drive, Reverse, Park? My moms saturn did that going into reverse. If you shift to drive then to reverse it was fine, just a quick fix.
03-15-2003 11:15 AM
dmg53 Thans for the reply. the dealer seems to be guessing and it's costing me time and money and the problem is still there.

thanks
Dennis
03-15-2003 06:07 AM
airworld2 this transmission has a lot of valve body trouble, can cause hard shifts and trouble codes have dealer check (tsb), tech service bulletins that deal with trouble.
03-14-2003 09:02 PM
dmg53
1994 Saturn Transmision Problem

This is not a hot rod problem, but I'm hoping I can find someone who has experienced my problem. The transmission of my 1994 Saturn SL1 bangs into gear. However, not all the time. After taking it to both a Saturn dealership in Philadelphia and an independent transmission specialist, both said it was a turbine speed sensor unit problem. Yet after each service center replaced the sensor, the problem re-occurrs. In addition, the check engine comes on simultaneously. The Saturn dealer wants to replace the wiring harness, but they won't guarantee this will solve the problem. I'm at the end of my rope with this problem. Anybody experience this problem? Appreciate any help.

Dennis

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -6. The time now is 01:53 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.