Hot Rod Forum : Hotrodders Bulletin Board - Reply to Topic
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Suspension - Brakes - Steering> Help With Bolt On Sub Frame Connectors On 69 Camaro
User Name
Password
lost password?   |   register now

Thread: Help With Bolt On Sub Frame Connectors On 69 Camaro Reply to Thread
Title:
  
Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
02-12-2006 04:56 PM
tmeyer Jim, I put these same sub-frame connectors on my 67. They hit my floor board so I notched the floor board and welded them in solid the the floor boaards. This was a hassle but I think this makes the structure much stronger.

The front of the sub-frame connector slides between the subframe and the bushing/bolt. Bolts/Nuts are included to be used on the side of the subrames where the instructions tell you to drill holes and install the Bolts/Nuts thru where the sub-frame and the connectors overlab. I did not do this. Instead, I welded the connectors to the sub-frame.

The back goes under the leaf spring brackets. My back tabs did not line up. the outer tabs needed to be raised up about 3/16". So I cut them off, bolted them to the body and tacked them. Then, I took them off and welded the in solid. After bolting these in, I welded them as well.

I can take some pictures if you still need them.
02-09-2006 11:46 AM
73oldsman Here's an article about installing them on a firebird, similar to you Camaro. May help some. http://www.highperformancepontiac.co...me/index1.html You could also contact their Tech Suppot section and maybe they could help you out. http://www.competitionengineering.com/default.asp
02-09-2006 06:38 AM
JimKramer
Help With Bolt On Sub Frame Connectors On 69 Camaro

Hey Guys,

I just got a new pair of Competition Engineering bolt on sub frame connectors for my 69 camaro from Summit. Does anyone have good directions on the installation preferably with pictures. They were not in the box. If not can you describe it in detail for me. The do's and don't's. Where to place the jack stands, etc. Anything you can give me is appreciated.

Jim

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -6. The time now is 04:35 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.