Hot Rod Forum : Hotrodders Bulletin Board - Reply to Topic
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Transmission - Rearend> Transgo Mod - Rear Servo Washer Stack
User Name
Password
lost password?   |   register now

Thread: Transgo Mod - Rear Servo Washer Stack Reply to Thread
Title:
  
Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
09-03-2006 06:17 PM
paulo 1 Yeah sometimes they send pieces just to measure distances,not to stay in the trans.In my case there was a washer to be used to check the size of a valve.Not to be installed,got it? But the text some times gives dual meanings...
09-01-2006 09:55 PM
Crosley reassemble the servo setup as OE........ use it.


always check the bores for wear from the sealing rings...... correct if there are ridges.
09-01-2006 07:33 PM
68NovaSS Thanks for responding, I understand the instructions - I think! It's pretty cut and dried the way it's presented.

It just seems odd that I wouldn't need any of the supplied spacer washers to make things fit back together. I've darn near sprained my neck and shoulders pushing up on the servo piston trying to make it mate! Even removed the O-rings to loosen things up for trial fitting.

Did they tell you any black magic or anything?

This is a '75 T-400.

Larry
09-01-2006 07:26 PM
paulo 1 I also had doubts with a Ford AOD shift kit and called them.Spoke with a Larry and a Glen.They were both very helpfull and stayed with me untill I had it understood.
09-01-2006 07:18 PM
68NovaSS
Transgo Mod - Rear Servo Washer Stack

I posted this on the tail of another thread, different issue, but re-posted here hoping someone will respond. I tried to call TransGo tech but no answers, probably too late in the day.

I bought a full manual Transgo-S kit but have an issue with the rear servo modifications. I removed the inner spring, seat and e-clip and installed the six washers as directed. I cannot get it even close to meeting the mounting surface with the cover, so started removing washers. Long story short, to get the cover to mate I removed all but two (leaving the original washer). Now I need to remove two additional to allow for band clearance. Heck, that puts me back to the stock configuration only with no spring and seat! I even removed the O-ring to ensure I was pushing it all the way up.

Anyone installed one of these kits? Am I missing something?

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -6. The time now is 04:36 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.