Hot Rod Forum : Hotrodders Bulletin Board - Reply to Topic
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > General Discussion> Hotrodders' Lounge> Introduce Yourself> 1962 Chevy Impala
User Name
Password
lost password?   |   register now

Thread: 1962 Chevy Impala Reply to Thread
Title:
  
Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
09-03-2006 08:30 PM
Bryan59EC I just started my 79 C-10 today after over a year of sitting.
Could very well be that by the time the fuel gets to the carb it will be oil primed

After a year of sitting, it sure was not happy about coming back to life.
And I'm still not sure if the wet spot near the drivers fuel tank is a rotted fuel hose or serious condensation in a muffler that blew last year.

I'll check it later---too damn hot outside this weekend.

Bryan
09-03-2006 05:28 PM
poncho62 welcome Mike......................Probably won't hurt anything. You could pull the distributer and hand prime the oil pump or at the very least pour a little oil down the open carb to lube the cylinder walls. i STORE MY CARS FOR 6 MONTHS IN THE WINTER AND START THEM UP WITHOUT INCIDENT.
09-03-2006 04:34 PM
michael brugman
1962 Chevy Impala

My name is Mike and I live with my wife and 4 children in San Diego, CA. I have had my 1962 Impala for 1 1/2 years, and my 3 boys ages 12, 13 and 15 have a blast cruising around town with me receiving thumbs up everywhere. Even though I am new to this site, I have a general tech question, which I know the correct answer to but need to cheat a little (maybe). I have had medical issues for nearly a year, and the Impala has not been started since last November 2005. I am better now and I want to enter it into it's first show on Tues 09/05/06. I'd normally change my own oil since nobody touches my car but me, although my lower back problems may preclude me. Here is the BIG question: WILL IT BE HARMFUL TO START THE IMPALA (350 cid) AFTER NOT BEING STARTED UP IN 10 MONTHS, AND TO DRIVE IT 3 BLOCKS TO HAVE THE OIL CHANGED?

Mike

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -6. The time now is 07:16 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.