Hot Rod Forum : Hotrodders Bulletin Board - Reply to Topic
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Electrical> Fried something in the dizzy...
User Name
Password
lost password?   |   register now

Thread: Fried something in the dizzy... Reply to Thread
Title:
  
Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
03-14-2007 09:43 AM
Sean's
Fried something in the dizzy...

Yeah if it's solid state it's Toast !
Replace it .
Smoke from under the capp indicate's that your runnin a Solid state ignition .

Typical of Electronic ignition's hooked up back ward's on the coil !

I came out of my house one mornin seen somebody had pulled all the wireing out on my motor on my Baja .

Was so madd some one had touched my car that in my haste I Hooked the wire's up back wards !

Poof black smoke !
Week later they did it again !
I did the very same thing , all over again ?
Go figure !

Sean
03-13-2007 06:26 PM
docvette Doc here,

See your SECOND THREAD..

Doc
03-13-2007 09:07 AM
Frisco
Quote:
Originally Posted by JJ350
Well, per my thread yesterday I correctly indexed my crank at 0* and did verify that the rotor was pointing to #1. My problem now is that when I hooked the coil up the wrong way Sunday I think I fried something in the dizzy. There was alittle smoke coming from under the cap. Anyway lastnight I went to start my truck and I have no spark.. Which is why I'm pretty sure the problem is in the dizzy, can anyone tell me what it could be that I fried? It's a points type dizzy. thanks.
Replace the condenser. If it is bad there will be no spark or a very weak spark.

Look at the contact surface of the points. If they are not welded together they may be badly burned or pitted. Better to replace them. Check the gap.

I would have asked this question in your original post for clarity of your problem to all who read the posts.
03-13-2007 08:45 AM
JJ350
Fried something in the dizzy...

Well, per my thread yesterday I correctly indexed my crank at 0* and did verify that the rotor was pointing to #1. My problem now is that when I hooked the coil up the wrong way Sunday I think I fried something in the dizzy. There was alittle smoke coming from under the cap. Anyway lastnight I went to start my truck and I have no spark.. Which is why I'm pretty sure the problem is in the dizzy, can anyone tell me what it could be that I fried? It's a points type dizzy. thanks.

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -6. The time now is 02:33 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.