Hot Rod Forum : Hotrodders Bulletin Board - Reply to Topic
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Engine> Poor gas mileage problem
User Name
Password
lost password?   |   register now

Thread: Poor gas mileage problem Reply to Thread
Title:
  
Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
03-19-2007 06:56 AM
red65mustang I always start and do step#1..."stock engine out of a 81 Camero"= do a compression test

my step #2 is mount a manifold vacuum source vac guage in the car, test drive it to confirm approx 25Hg plus on a mild downshift with the motor warm = valves and rings are sealing

is it your size 12 foot or the motor causing the lousy mpg....vac guage will tell you while driving:
just to illustrate....
lead foot "drop the hammer" = guage will show 10Hg or less=carb is full rich (A/F 13:1) and vac advance timing is close to none and mech timing is only 24* or so
"squeeze" the pedal gradually = 15Hg-18Hg= carb is optimum A/F (15:1) ratio and vac advance is full on adding 14* or so to the 24*

squeeze the pedal and Hg still drops to 10....it's the motor

(mounted on the dash like mine...it is a "mpg police"= stay in the green zone or else!)
03-19-2007 12:02 AM
JeffB
Carb Tune?

You might want to run a vacuum check,and look at a power valve change dropping to a lower size may help,a lot of times guys will change jets and get zero results.
09-14-2006 03:50 PM
poncho62 I think that the engine is operating out of its optimum RPM range....in other words, it is being lugged too much.

I bet a set of 3.23s or so would get better mileage and would be a lot peppier too.
09-14-2006 03:38 PM
ken47
Poor gas mileage problem

I am running a 267 SBC in my new T bucket. It's a stock engine from an 81 Camaro. I'm using a new Holley 390 CFM carb (down jetted 2 sizes for 3000 ft altitude here) on a weiand 8007 dual plane manifod with a square/spreadbore carb adapter, 180 deg F thermostat, a TH-350 transmission with 2.79 rear end and 295R14 tires. I am using a stock points type distibutor (don't know the year) with a points elimination kit in it. I am using a flame thrower coil (40K volts with no balast resistance). My problem is that the gas mileage is really poor. It seems worse at low speed city driving. I thought the gas mileage would be very good with ths set up. Any suggestions as to where I should look to improve things.

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -6. The time now is 05:11 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.