Hot Rod Forum : Hotrodders Bulletin Board - Reply to Topic
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Electrical> Doc--I gotta quicky stupid question for ya--regarding battery chargers.
User Name
Password
lost password?   |   register now

Thread: Doc--I gotta quicky stupid question for ya--regarding battery chargers. Reply to Thread
Title:
  
Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
09-03-2007 03:11 PM
Bryan59EC
Quote:
Originally Posted by docvette
Doc here,

Put a DVOM across the charger and look for the flashing + / - display..follow that..
Doc
I guess I had a big time brain fart----I KNOW this, and my meter tells me stuff like this .

Need more COFFEE

Thanks
Bryan
09-03-2007 02:45 PM
docvette Doc here,

Put a DVOM across the charger and look for the flashing + / - display..follow that..

It is possible to reverse charge a FLAT dead battery "000" DCV, backward! Be careful of that..


Doc
09-03-2007 02:08 PM
Bryan59EC
Doc--I gotta quicky stupid question for ya--regarding battery chargers.

When I went to Vegas for Dad's funeral, I also acquired some of his goodies.
A couple of 'em being old battery chargers.

Since my new digital newfangled charger will not bring a battery up unless it has some sort of charge, I thought I would use one of Dad's old chargers.
He had a 10amp and a 6amp regular old fashioned analog scale thingies.

Well---the 10amp charger that I used, had the red insulators on the clip marked 'neg' and the black insulators on the clip marked 'pos'

Not being sure of what this meant exactly----I disconnected everything from the battery and charged it.

Red insulator clip to 'pos'

My question-----with the battery disconnected, does it really matter how these are connected?? (my batt charged okay)

How can I check the polarity of the charger just to be sure? Don't really want to damage anything ---- or the charger as it is kind of handy for the cars that just sit for months before I start em.

Have no idea what my newer charger needs to have voltage wise before it will go ahead and charge----just know that if the battery is too low, it faults out .

What good is a charger----if it won't charge a battery??

Bryan

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -6. The time now is 08:32 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.