Hot Rod Forum : Hotrodders Bulletin Board - Reply to Topic
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Hotrodding Basics> another chop job
User Name
Password
lost password?   |   register now

Thread: another chop job Reply to Thread
Title:
  
Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
12-01-2014 07:36 PM
knight hawk the small screws in the angle supports were rusted solid to little threaded plates, some of metal itself was bent, , so, a little heat , and some water ,,,, like new again !
12-01-2014 07:24 PM
knight hawk as I said it's an original steel visor, needed to widened ...
12-01-2014 07:19 PM
knight hawk and here's a couple more...
12-01-2014 07:17 PM
NEW INTERIORS Looking very nice....
12-01-2014 07:15 PM
knight hawk
visor

finally ! here are some visor pics....it is an original Fulton visor, very popular in it's day. And totally adjustable....
11-22-2014 09:24 PM
knight hawk OK maybe tommorrow
11-22-2014 11:30 AM
deadbodyman Looks great man, how about a side view... I'm thinking about putting a visor on my 48
11-22-2014 11:16 AM
knight hawk I'm Back !!!!!!! here some pretty cool pictures of the car , with the recently added visor...........PS, the car still running great ! Aafter close to 5 years now, only repair has a dash bulb........and tires
04-30-2013 07:48 PM
knight hawk last picture didn't load, if not here is again OOP'S , I see it's in , was alittle too big
04-30-2013 07:33 PM
knight hawk Because this car (and others) sit so much, and usually takes some cranking to get the the fuel up, I decided to install an electric fuel pump near the tank, to 'prime ' the system. Now, all I do is hold the button in till the pump sound changes, (pressure build up ), and 2 pumps on the throttle, starts right up ! I mounted the pump direcrtly to the metal of the body, to make sure the 'sound' is heard inside the car. An ACC wire from the fuse panel, and button under the dash....
11-11-2012 10:35 AM
MARTINSR Sounds like a blast!

Brian
11-11-2012 10:29 AM
knight hawk a little up date here.... not been driving it it too much, except on Friday nites, a couple times a month. The 'used' engine is getting a littl louder lifter noise, but goes away after it gets hot. Got a click in the rear suspension when you step on it or hit the right bump. I think I'm getting some 'bump steer' effect at certain speed, but I think thats cause of the change in the trosion bars setting to raise the front height more. I beleive I was off on the ride height when I built the front frame and added the torsion bars set up . The car still draws a crowd ! Was at the Veterns Days Car show here testerday.... Get this ! At the car show, a man named Phil Spain came over, looked at the car, gave me lots of compliments on the car build, he said he was a friend of and worked with George Barris. Then later, I overheard him talking a another guy I knew, and knew he was for real !!! ....P S , I got a 2nd place trophy that day
10-08-2012 01:36 PM
MARTINSR You need to post in the Picture game thread, look at the last challenge, post #75.

http://www.hotrodders.com/forum/pict...ad-220831.html

Brian
10-07-2012 08:10 PM
knight hawk just a quick note here....kind of update. Haven't driven it alot, been getting it out every couple weeks, I've noticed a clunk some where when I step on it ,. It kinda sounds like the front/suspension. Also, the motor (318) has some lifter noise, but as this was a''junk'' engine that decided to run, and had some rust on the cam, so I'm lucky it's still running. Maybe, I'll get to rebuild it (here on this forum ) later,like maybe in the spring.......glad to see y'all still readin this....
06-12-2012 06:29 PM
deadbodyman beautiful, you could make post cards,just look at that big blue sky... I'm bringing my tent...
This thread has more than 15 replies. Click here to review the whole thread.

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -6. The time now is 03:11 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.