Hot Rod Forum : Hotrodders Bulletin Board - Reply to Topic
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Garage - Tools> Issue with New Jet Drill Press...
User Name
Password
lost password?   |   register now

Thread: Issue with New Jet Drill Press... Reply to Thread
Title:
  
Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
01-09-2008 05:17 PM
11echo I have and older Jet drill press only 4 speeds. I picked it up at the Pomona swat meet in Calif for $40. It was missing the pinion rack and hand crank. I called Jet and told them what I had ...they didn't believe me when I described it! *G* ...That is was only a 4 speed machine. But after running down a local historian, they coughed up some suggests and got the parts ordered, they worked fine ...nice to be able to drill a straight hole once again ...definitely better then hand held drill!!! It would be nice to have more selection of speeds, and a bigger table. But for right now it fills the bill fine!
01-08-2008 06:25 PM
71gtx Ok I got a new chuck and arbor shipped to me by Jet and I still have a wobble in the chuck. Problem must be in the machine. I drove a 2 hr round trip to the closest Menards with a press, and it happened to be a floor model. I asked to have them turn it on so I can see it run. What happened...The DAMN thing was wobbling. not as bad, but still a wobble. Jet said they would put a model together at their headquarters and ship me a working one. By the way, anyone like Grizzly's machines?
01-06-2008 08:46 PM
russlaferrera I have a 10 year old Jet JPD 17MF. It worked great right out of the box. I change chucks and arbors for other things like a tapping head or larger chuck when needed, without any problems.

IMO there is a problem with the arbor to quill fit. As stated there may be a burr keeping the parts from mating properly.
01-06-2008 06:06 AM
Kevin45
Quote:
So Jet's=no good huh? What kind of presses are recommended?
Jet is a pretty good piece of equipment. It will give you a lot of years of use. As far as seating the chuck, I really can't help you too much without seeing what type of arbor it is. From what ZI am reading though the problem is the arbor into the drill chuck and not the arbor into the quill of the press. Measure the depth of the hole in the chuck and see if the arbor is not bottoming out in the chuck before it fully seats. You may have to gring the end off of the arbor a little to let it seat further down in.

Kevin
01-02-2008 09:38 AM
35WINDOW I have that same Drill Press-I did have a problem seating it initially, but it finally did pull into place (it is a tight, tapered fit)-
01-01-2008 08:09 PM
61bone After I sold my Wilton (recommend but to big for me to move), I bought a Craftsman commercial. Not perfect, but does what I want it to.
01-01-2008 04:29 PM
71gtx I appreciate the advice, but I shouldn't have to go through this kind of hastle for a new machine. So Jet's=no good huh? What kind of presses are recommended?
12-30-2007 09:48 PM
Kruzin Karl It was a "tongue in cheek" kind of comment, lot's of sarcasm intended, Chinese made.
12-30-2007 09:42 PM
66GMC
Quote:
Originally Posted by Kruzin Karl
Uhh, where is Jet made?
Jet Tools & Equipment

Is this the right "Jet" tools that we're talking about?
They are available in Canada through USI / AGI distributors.
(USI = "Uni-Select" ... Auto Parts Plus, Bumper-To-Bumper)
(AGI = "Acklands/Grainger)

Made off-shore ... China, I think.
They also have a "cheaper" line ... "ITC Tools"
12-30-2007 08:29 PM
Kruzin Karl Uhh, where is Jet made?
12-30-2007 03:14 PM
61bone Do the chuck and the arbor have the same taper? Chucks are nearly always Jacobs taper as is one end of the arbor. The long end of the arbor is usually Morse taper.Is the arbor taper and the quill taper the same? does the tang on the arbor fit in the slot in the quill? If yes to these, are there any burrs on either the chuck or arbor? Is there any cosmoline or other corrosion preventative on either one? If yes, remove and polish. Must be clean. If no, clean anyway. then, put the arbor in the quill and check runout. By snugging up the quill bore some runout can be removed but do not squeeze quill. IIt should still move freely. If still out, remove, turn 180dg and reinstall. Check runout again. If still out, thats not unusual for Jet. At this point, go to your local machinist supply and buy an arbor and chuck of good quality and have them mount it.
If the runout is acceptable, freeze the arbor overnight in the deepfreeze. Heat the chuck to 300 dg in the oven. Have the dogs in the chuck turned down flush or less. Have a brass hammer and a piece of 2x4 handy. slip the arbor into the chuck and give the tang end of the arbor a couple taps with the chuck set firmly on the board. If the tapers are true, this will seat it squarely. You have only a couple seconds to do this.
Good Luck. Personally, I'll never own another Jet tool
12-30-2007 08:17 AM
Youngster
Drill press issue

Is the chuck keyed? The flats on the top of the chuck should line up with the slot in the arbor.

Youngster
12-29-2007 12:18 PM
71gtx
Issue with New Jet Drill Press...

I recently purchased a 16.5" jet drill press. I got to the end of the assembly and I noticed that the arbor would not go down fully into the chuck. Upon putting the arbor and chuck into the spindle, I turned it on and had a large wobble in the chuck. The bearing seems fine, but as I look into the open end of the chuck, I can see that the arbor hasn't reached the mating surface that it should meet. I took the machine back, got another and had the same problem. Any suggestions?

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -6. The time now is 10:34 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.