Hot Rod Forum : Hotrodders Bulletin Board - Reply to Topic
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Suspension - Brakes - Steering> 2003 Chevy 4X4 DIESEL HELP!!!
User Name
Password
lost password?   |   register now

Thread: 2003 Chevy 4X4 DIESEL HELP!!! Reply to Thread
Title:
  
Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
04-16-2008 07:01 PM
THE ROOSTER THANKS TO ALL!!!

It turned out to be the power steering pump, and my neighbor also is having the boost valve replaced!!!
04-15-2008 08:45 PM
Blazin72 This is a very informative site that may help you out:
http://www.babcox.com/editorial/bf/bf030542.htm

Quote:
Originally Posted by Bull_81073
I know that technology has come a long way from the vehicles I'm used to working on but I think that the power brakes still use vacuum to do the boosting.
Quote:
Originally Posted by Bull_81073
Diesel engines don't use vacuum!
It's not just diesel pickups that use Hydroboost systems. I know that at least the 3/4 ton and up gas powered GM pickups also use Hydroboost. My gas '00 Silverado has it, my friends gas 97 has it and my uncles '93 Suburban, also gas, uses it. It works great.
04-15-2008 08:29 PM
OneMoreTime Would be interesting to hear what the problem turned out to be??

Sam
04-15-2008 07:08 PM
Bull_81073 I'm an idiot!

I didn't look at your post closley enough. Diesel engines don't use vacuum! Look at the following quote.

"HYDROBOOST POWER BRAKE SYSTEMS - Diesel engines do not create enough useable vacuum to actuate the vacuum power brake booster. The alternative is a hydraulic-assisted power brake boosteror hydrobcmst. This system is currently found in the1 1/4-ton CUCV and the 3/4-ton CUCV Blazer, both powered by the 366 cubic inch V8 General Motorsdiesel engine. Both units are found throughout the NCF and at some public works stations. The hydroboost uses hydraulic pressure developed by the power steering"

Check the fluid first. If it's full the pump may be shot
04-15-2008 07:05 PM
Bull_81073 Not real sure what single problem could have caused that... Strange. This may be a stupid question but have you checked the fluid in the powersteering? I'm jumping to conclusions here but could someone have sabotaged the truck just to mess with him? I know that technology has come a long way from the vehicles I'm used to working on but I think that the power brakes still use vacuum to do the boosting.

An easy way to check if vacuum is being applied to the break system is to turn the engine off. Then press and release the break pedal several times. Hold down the break pedal and then fire the engine. If the break system has a vacuum supply the pedal should go soft. If not then you need to run down the vacuum line.
04-15-2008 07:03 PM
OneMoreTime I know it sounds like it sounds but did he check the fluid..that is a hydroboost on a diesel pickup and if there is no fluid in the powere steering pump then nothing will work.. Could be the pump has failed as well as the power steering pump runs all of that..I would start there..Fill the reservoir and crack a line to see if the pump is pumping..Another thing to look at..

Sam
04-15-2008 05:54 PM
THE ROOSTER
2003 Chevy 4X4 DIESEL HELP!!!

2003 - 6.6 turbo diesel in chevy pickup - 4x4. Belongs to my neighbor. He got out of it yesterday, no problems. Drove it today and had no power steering or power brakes. No warning lights came on! Anyone familar with a problem like this?

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -6. The time now is 06:31 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.