Hot Rod Forum : Hotrodders Bulletin Board - Reply to Topic
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Engine> my 671 isn't making boost?
User Name
Password
lost password?   |   register now

Thread: my 671 isn't making boost? Reply to Thread
Title:
  
Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
07-15-2008 09:35 AM
rags70ss
re: my 671 isn't making boost?

My 6-71 blower with a 256 cam will make max boost at 6K the boost will start at about 2 # at 2 K or so and increase with motor RPM. Oh ya its 17 % overdriven 11# boost.
04-26-2008 08:23 AM
joe k darkostoj, I think your questions will be answered if you go to the Holley web site, go to tech service , then holley tech library,and then supercharger tech information. They have a good explanation of boost. Joe k
04-25-2008 12:00 AM
68NovaSS
04-24-2008 10:45 PM
F-BIRD'88 What you're seeing on your boost guage is pretty normal.
"boost" is a reading of what is not getting into your motor.
Its what is left over. You camshaft valve timing will effect the boost curve and boost response.
Normally with the drive ratio you are using you will see boost start at 2500rpm +/- and build as the motor revs higher. Pobabily not peaking out until 5000rpm or higher.

If you erwe to make your eninge breath more efficiently, say a cam change or less restrictive cylinder head ports then you would see less boost on the gauge and make more engine power. Its how much power you make that matters.
not how much boost ( manifold back pressure) the gauge reads.
if you were to make the motor less efficient (smaller cam, more restrictive heads smaller valves and ports and/or more restrictive exhaust, you would see the boost gauge go up (and power go down) because less of the air available in the manifold is getting into the motor.
Cam timing (overlap can have a big effect on the boost curve. if the camshaft has too much overlap, some of the boost will go right thru the motor and out the exhaust i the low/mid rpm range resulting in a slow boost curve that all of a sudden comes on.
Just remember that the boost is not an indication of how much power you're making, its an indication of the amount of air that is being pumped by the blower but not consumed by the engine.
Your carbs are not too big or too small. Changine the blower drive ratio will increase peak boost and quicken the boost response ( more mid range boost) but just be aware that there are practical limitations on how much boost you can run without detonation on pump gas. For 92 octane fuel with the cr you have, you're set up pretty well right on. More boost ( blower drive ratio) will require higher octane fuel or lower engine compression ratio or water injection to avoid engine killing detonation.
how much boost do you have at 2500rpm,3000,4000,6000rpm with full throttle?
Should be a smooth progressive building boost curve and power curve. If it has little or no boost (and power gain) in the low/mid (3000ish) rpm range and then all of a sudden at 4500rpm you have a ton of boost then the camshaft may be wrong for your motor. (too much overlap) causing overscaveging.
Like I said you have to take the boost gauge reading relative to how much power the motor is actually making.
Do you know the cam grind that you have in your motor.
I don't suspect a problem, just asking.
04-24-2008 08:42 PM
garyroushkolb A roots blower is an air pump, restrict the inlet or restrict the exhaust and it won't produce boost. Your not going to get boost until you open the butterflies and put the motor under load. I'd increase the drive ratio to 1 to 1 even with 8.5 to one compression and make sure I have good gas and a conservative advance in the ignition. The motor will be lots more fun to drive and won't self destruct unless you ignore any detonation signs. Remember this is street driving and your full throttle time will just be 2 or 3 seconds at best.
If you want to check the blower condition take it off and turn it upside down and check the clearance with a feeler gage. Bottom should be about .006 minimum and most street blower should be .008 with .012 needing to be refreshed by a professional. The timing should be .011 between the rotors and look at the condition of the rotor tips also for damage. My guess is you should try and up the drive ratio and give it a try! Gary Roushkolb Superchargers.
04-24-2008 08:16 PM
68NovaSS If you go 1:1 on a 350 it would produce 15.3 #'s of boost. On a 350 with only 8.5:1 static cr - with 14#'s of boost, that's going to raise your effective cr to 16.6:1. 15+ #'s of boost with a roots type blower is a lot for the street, can your motor hold that?

I have an 8-71 on a 383 with two BG 750 BC's on the street, it's very streetable, if not a little brutal. I opened up all eight primary idle air bleeds to help idle quality, and jetted it down two numbers on both sides, other than that, nothing.
04-24-2008 05:19 PM
carsavvycook Twin 600's are too much for a 350CID, or 383 for that matter. You are most likely over carb'ed, and running too much air/fuel for the street. Switch to twin 500's to cut down on the volume of air and rejet to 107's, with 73-42(part #1455) metering rods with 8"(silver) step-up springs. This combo gets a full boost of 20 earlier with a 1.1 blower drive.
04-24-2008 03:58 PM
techinspector1 I'm not a blower guru by any means, just thinking out loud.....
a restriction in the air supply will prevent reaching boost. Have you checked to see that the carbs are opening fully? Have you tried running 1:1? What cam are you using? What header size?
04-24-2008 03:04 PM
darkostoj
Quote:
Originally Posted by 68NovaSS
That's a cogged belt, won't slip. You sure you're not making boost at lower rpm's? Driving down the freeway at steady rpm's you're not going to be into boost anyway, as you said, boost comes in under load. If you hammer it from idle you're going to have boost if the blower is spinning! It's not an old blower with rotor to case clearances out of spec is it?
it is an older blower, but it doesnt really have that many miles on it. It definately doesnt show any boost right away when there is load on the motor.
04-24-2008 02:49 PM
68NovaSS That's a cogged belt, won't slip. You sure you're not making boost at lower rpm's? Driving down the freeway at steady rpm's you're not going to be into boost anyway, as you said, boost comes in under load. If you hammer it from idle you're going to have boost if the blower is spinning! It's not an old blower with rotor to case clearances out of spec is it?
04-24-2008 02:42 PM
boatbob2
6-71

Hi,check your belts,they may be slipping.
04-24-2008 02:38 PM
darkostoj
my 671 isn't making boost?

i'm not sure whats going on here. I've been doing some reading and it seems like most people go to full boost as soon as they introduce load on the motor? Mine doesnt get to full boost until I'm well into 4000+rpm at WOT...I thought that was normal!

what would cause my blower to not make full boost like that?! Its a weiand 671 blower with dual eddy 600 carbs up top on a 350 with 12% underdriven pullies.

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -6. The time now is 05:19 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.