Hot Rod Forum : Hotrodders Bulletin Board - Reply to Topic
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Engine> 1999 Silverado Evap Code
User Name
Password
lost password?   |   register now

Thread: 1999 Silverado Evap Code Reply to Thread
Title:
  
Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
07-18-2008 12:39 PM
sbchevfreak P0440 EVAP System No Flow During Purge


Does the MIL go off after you fill the tank, and then come back on after you drop below 1/2 a tank? If so, your code is caused by a filter on the evap purge pump. In '99 up to '03-4 trucks, they put these on the frame right where they could collect mud and road grime, ect. When they plug, the evap pump cannot draw in fresh air, upsetting the pressure in the system, and sets P0440. The pump kicks on after the fuel level drops below 1/2 a tank. Unfortunatley, in '99 you cant remove the darn thing to clean it, and it used to cost around $300 for the filter relocation kit.
07-18-2008 10:31 AM
carsavvycook Every Shop should have one of these. But that is OK, I have 3 other shop owners that bring me vehicles to diagnose. So when I say it's a money maker I meen it.
07-18-2008 10:26 AM
ernkazern That's the same one I have, I agree it's a great smoke machine.
07-18-2008 08:45 AM
carsavvycook
Quote:
Originally Posted by ernkazern
Carsavvy is that a Smoke Pro Total-Tech that you're using? Have you tried using the colored oil that acts as a dye? If so, how did you like it?
Yes it is, and I love it. It put's out an amazing amount of smoke. I even use it to find vacuum, and exhaust leaks. So it gets used almost daily. It's a real money maker for me. I even rent it out, so it is paying for itself literally. I prefer to use the scented baby oil, because you can smell it without seeing the smoke. A big bottle of baby oil lasts me almost 2 years.
07-18-2008 05:49 AM
ernkazern Carsavvy is that a Smoke Pro Total-Tech that you're using? Have you tried using the colored oil that acts as a dye? If so, how did you like it?
07-18-2008 05:46 AM
ernkazern The purge valve is on the passenger side of the engine and should have a dark green and a white wire connected to it. The canister vent valve is on the drivers side of the engine compartment and should have a white and a pink wire connected to it. A P0440 is for a large leak, a smoke tester connected and used correctly should be able to show a large leak with no problem whatsoever. One little trick is to take the gas cap off when filling the system initially with smoke. When you see the smoke coming out of the filler tube replace the gas cap then start testing. The system will fill much faster if the gas cap is off.
07-17-2008 09:33 PM
carsavvycook I have an EVAP smoke machine, and I test on average 5 each month. It has a gauge, and a pressure ball gauge on it also. If there is a small leak, it will not show smoke, just a pressure drop. I have found cracks in plastic fuel tanks, fuel pump/sender gaskets, and evap grommets, on the tops of fuel tanks. One of them had a small crack in the fuel fill hose.

It would be wise to drop the tank, and apply pressure to it, to find these.
07-17-2008 09:05 PM
Matt Balik
99 Silverado evap problem

A local garage tested the system with their smoke machine. It threaded into the test port downstream of the purge valve, power is supplied from the vehicle's battery. I don't know if it is specifically for testing automotive evap systems or not. At any rate, he was unable to get any smoke into the system. He tried both with the test port schrader valve in place and removed. None of the evap system piping was disconnected at any location during the test.
07-17-2008 08:45 PM
ernkazern The valve you replaced is the purge valve. Did you use an automotive evap smoke machine to test the system with?
07-17-2008 08:08 PM
Matt Balik
99 silverado Evap problem

I'm sorry for the confusion. The valve I replaced is the solenoid vent valve located in the front part of the intake manifold. I assumed it pulled the vapors out of the charcoal cannister when it opens using manifold vacuum and introduces the vapors into the combustion process. The charcoal cannister has three hard plastic lines exiting from it. One marked AIR that runs to a location on top of the fuel tank. (I can barely feel the end of it with my hand) I assumed this was the fresh air intake for the system. With this line disconnected from the cannister I am able to blow air through it. The second one is marked VENT, and goes into the top fuel tank. With this line disconnected from the cannister I am able to blow air through it also. The third line is marked PURGE. It goes to the to the solenoid vent valve mentioned above. With this line disconnected at the cannister I am unable to blow air through it unless I disconnect thte other end from the solenoid vent valve. These markings are on the charcoal cannister itself where these three lines connect to the cannister. If there is another vent valve in this system, I am unaware of it's location. The clicking noise you mentioned when the solenoid valve tests itself is what I heard after the engine came up to temperature. I really appreciate your taking the time to help me with this problem and apologize for my ignorance.
07-16-2008 04:02 AM
ernkazern The charcoal canister vent solenoid is normally open. It's where the clean air comes into the charcoal canister when the system purges. When you smoke test the system the smoke will come out of the normally open charcoal canister vent valve. The only time that valve is closed is when the system tests itself. The only noise you should hear from that solenoid is a click when it closes and a click when it opens. I'm not sure what valve you're talking about.
07-15-2008 08:17 PM
Matt Balik
99 silverado Evap problem

Yes, the vent solenoid was the one I replaced. I also confirmed the solenoid was working by letting the engine come up to temperature, I can hear it running, should have done that before I bought a new one! I don't understand why I should see smoke exiting from the vent solenoid though?
07-15-2008 07:49 PM
ernkazern It's sounds like you may not have let the system fill with smoke long enough. You should see smoke coming out of the vent solenoid valve unless you're activating it or pinching the hose off because it's normally open. Does your smoke machine have a gauge on the side to tell you if the system is tight? Leaking vent solenoid valves are a common problem with this vehicle. Is the vent solenoid the one you replaced? Btw, all of the smoke machines I've used required you to remove the schraeder valve to fill the system with smoke.
07-15-2008 07:37 PM
Matt Balik
1999 Silverado Evap problem code

The code is P0440. I checked the system for leaks using a smoke machine. I didn't see any smoke escaping, so would that not indicate a tight system? I even removed the schrader valve from the connection to insure the smoke could get into the line. Then I replaced the schrader valve. If the leak were at the tank fill pipe I should have observed smoke coming out of there, right? Is there anything inside the fuel tank that could trigger this code?
07-13-2008 10:58 AM
T-bucket23 Whats the code
This thread has more than 15 replies. Click here to review the whole thread.

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -6. The time now is 04:58 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.