Hot Rod Forum : Hotrodders Bulletin Board - Reply to Topic
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Engine> Clear Fuel Filter Almost Empty
User Name
Password
lost password?   |   register now

Thread: Clear Fuel Filter Almost Empty Reply to Thread
Title:
  
Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
07-26-2008 05:49 AM
red65mustang John,
it won't/can't stay full constantly because the check valve in the fuel pump will leak down as the motor cools and gravity is moving the gas to be more level with the the much lower gas tank supply.....that's totally normal....
(LOL, mount your gas tank on the roof and it will stay full)

compared to alot of pumps sold today your's is working excellent!!! (my check valve holds pressure for maybe 30 minutes)

all that a mech pump is.... is the rubber diaphram pushes/pulses a bit of gas past that one way check valve and spring combo and if the carb bowl is full so that the needle and seat are closed the line will build pressure...the check valve spring that limits/bypasses the gas at only 5.5psi isn't strong enough to hold the pressure forever....
07-26-2008 12:56 AM
swcash You have an air pocket trapped in the filter housing. This won't hurt anything until the filter starts clogging up and you need the part of the filter that the air pocket is occupying.
The fuel is not moving fast enough to force the air out. Try disconnecting the fuel line from the carburetor and put the end in a 2 liter bottle and start the engine. The free flow of the fuel may force the air out. Once the air is displaced with fuel you should be ok unless there is a leak in the fuel line and you are picking up air.
If you run out of fuel or run the tank too low the air will probably be back.
Squido
07-21-2008 08:10 PM
JohnTN Maybe you are right. The element stayed empty (10% full) from 1 p.m. till about 6 p.m. this evening, last time I looked. Then I just looked at it again, 10 p.m., and it is now 90% full of gas, and the pressure gauge reads zero.

If it does it again tomorrow, I will loosen the hose clamp on the inlet to the filter and see if I get any vapor or air released and fuel flow into the filter.

Thanks,

John
07-21-2008 05:29 PM
vfr172pilot Mine stayed empty most of the time cold or not... there was always a lot of pressure when I disconnected the line.
07-21-2008 05:12 PM
Mertz Mine has been that way for years and I haven't had any problems with how the car runs. Mine is about half full or less all the time. I haven't tried to bleed it because it hasn't caused a problem. It might be worth a try to disconnect the line from the outlet side of the filter and fill it and see if it stays that way after driving for awhile.
07-21-2008 04:36 PM
JohnTN If it was vapor lock, seems like it should fill solid when the car is first started cold, but it doesn't.
07-21-2008 12:55 PM
vfr172pilot I had the same problem with my 69 Mustang... turned out to be vapor lock. I re-routed the fuel line about a half-dozen times until I found a route it "liked".
Good Luck!
07-21-2008 12:00 PM
JohnTN
Clear Fuel Filter Almost Empty

I just finished addressing a fuel starvation problem which turned out to be sender unit gasket sealer dripping down into the gas tank and ending up in the clear filter between a pressure gauge and QJet inlet. I rinsed the tank out with water, dried it, blew down the steel fuel line from mechanical pump suction back to tank, then reinstalled sender with new rubber gasket and reinstalled tank. Left mechanical fuel pump untouched. And replaced fuel filter with clean one.

First two times out the car has run fine but when I shut it down and check under the hood, the clear filter is almost empty and the pressure gauge (just two inches upstream of the filter) shows about 4 psi. Gradually the pressure bleeds off over a couple of hours but the filter does not fill.

Starting the car and idling or short pulses of throttle show fuel slowly trickling into filter and pressure at steady 5-5.5 psi.

I don't understand why the filter doesn't fill solid. And how can there be 4 psi of pressure on the gauge and very little fuel in the filter? I disassembled the filter once to check for clogged inlet but it was clean. And there was nothing in the 3/8 inch rubber hose connecting the gauge to filter inlet.

Shouldn't the clear filter fill almost solid with fuel? Any theories? Can it just be air pressurized in the line?

Fuel pump is new with 6K miles on it.

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -6. The time now is 11:46 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.