nitrous problem - Hot Rod Forum : Hotrodders Bulletin Board
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Engine
User Name
Password
lost password?   |   register now

Reply
 
LinkBack Thread Tools
  #1 (permalink)  
Old 03-15-2013, 09:10 PM
Registered User
 
Join Date: Apr 2009
Location: canada
Posts: 19
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
nitrous problem

hi i have 383 camaro built right all forged msd 850 holley with nos plate system 175 shot.I have msd activation switch turns nos on at 4000 rpm and off at 7000 rpm the problem im having is shooting flames out of pipe actually caught carpet on fire inside car.I thinks its worse at end of quarter mile the exhaust is a y pipe into single 3.5 inch pipe but has a dump before sigle pipe.Ouls this happen because of y pipe design?Im also wondering if my switch is faulty and nos isnt turning off.The fuel system is electyric holley black pump any advice greatly appreciated car is automatic if it matters thanks in advance

    Advertisement
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2 (permalink)  
Old 03-15-2013, 10:30 PM
Registered User
 
Last photo:
Join Date: May 2009
Location: S/E Michigan
Posts: 653
Wiki Edits: 0

Thanks: 0
Thanked 9 Times in 9 Posts
Flames out the exhaust indicate a overly rich mixture with unburned gas being ignited in the exhaust.

Nitrous by itself will not burn/ignite. Maybe your fuel solonoid is open and the nitrous solonoid isnt, causing an excess for fuel.
Reply With Quote Quick reply to this message
  #3 (permalink)  
Old 03-15-2013, 11:51 PM
Registered User
 
Join Date: Apr 2009
Location: canada
Posts: 19
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
nitrous

both solenoids are new if nos solenoid wasnt working i wouldnt be feeling the nitrouswould i?
Reply With Quote Quick reply to this message
  #4 (permalink)  
Old 03-16-2013, 05:01 AM
33Willys77's Avatar
Registered User
 
Join Date: Jan 2013
Location: Wisconsin
Posts: 406
Wiki Edits: 0

Thanks: 7
Thanked 57 Times in 55 Posts
Have you run it without nitrous? Was the motor tuned without nitrous? What do the plugs look like after 1 run ---- Need a fresh set of plugs, do a run and read them. Do you have an O2 sensor?
Reply With Quote Quick reply to this message
  #5 (permalink)  
Old 03-16-2013, 07:24 PM
Registered User
 
Join Date: Apr 2009
Location: canada
Posts: 19
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
nos

yes it was ran withjout nos.
no o2 sensor
never had a chance to read plugs
Reply With Quote Quick reply to this message
  #6 (permalink)  
Old 03-16-2013, 07:25 PM
Registered User
 
Join Date: Apr 2009
Location: canada
Posts: 19
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
nos

was tuned before nos and retarded after nos
Reply With Quote Quick reply to this message
  #7 (permalink)  
Old 03-16-2013, 10:04 PM
33Willys77's Avatar
Registered User
 
Join Date: Jan 2013
Location: Wisconsin
Posts: 406
Wiki Edits: 0

Thanks: 7
Thanked 57 Times in 55 Posts
What did your plugs look like without N2O? Does your floor get that hot that it starts the carpet on fire? That would be turning the metal red to do that. How do you know there are flames? 175HP N2O is not a big bunch, so you should not be seeing anything different out the pipe - however you are seeing it. ??
Reply With Quote Quick reply to this message
  #8 (permalink)  
Old 03-17-2013, 04:27 PM
Registered User
 
Last photo:
Join Date: May 2009
Location: S/E Michigan
Posts: 653
Wiki Edits: 0

Thanks: 0
Thanked 9 Times in 9 Posts
Quote:
Originally Posted by kamarofreek View Post
both solenoids are new if nos solenoid wasnt working i wouldnt be feeling the nitrouswould i?
Just becasue they are new doesnt mean they are working correctly.
Reply With Quote Quick reply to this message
  #9 (permalink)  
Old 03-18-2013, 10:58 AM
1Gary's Avatar
Registered User
 

Last journal entry: 383 dyno sym
Last photo:
Join Date: Oct 2010
Location: Roch,NY
Age: 66
Posts: 1,526
Wiki Edits: 0

Thanks: 201
Thanked 156 Times in 142 Posts
A local friend of mine works at Delco and machined his own nitrous system for his 442 455.Outrageous fast car.He was pouring in more nitrous then anyone I know.He was tearing out the main saddles out of the block and twisting the cranks.Broke afew too.But he knows his Old's and was way in front of the tune.Never any flames.............Huge back bumper wheelstands.
Reply With Quote Quick reply to this message

Recent Engine posts with photos

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
nitrous problem tomthecomic Engine 3 09-10-2007 06:11 PM
nitrous camaroracer1613 Engine 2 08-04-2005 06:58 AM
nitrous 82c10 Engine 8 07-17-2005 02:27 PM
Nitrous Problem, Maybe fuel pump? esears Engine 7 05-02-2005 05:21 AM
nitrous 70camaro Engine 3 02-17-2003 11:19 AM


All times are GMT -6. The time now is 08:34 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.