no forward but has reverse in th350 - Hot Rod Forum : Hotrodders Bulletin Board
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Transmission - Rearend
User Name
Password
lost password?   |   register now

Reply
 
LinkBack Thread Tools
  #1 (permalink)  
Old 12-01-2010, 08:15 PM
Registered User
 
Join Date: Dec 2010
Location: madison, virginia
Posts: 13
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
no forward but has reverse in th350

So im new to this site. Gonna try to give lots of detail. Have a 84 k10 th350 trans, 350 engine 35 inch tires. I broke the input shaft last year. Rebuilt trans and put another input shaft in. Used hughes overhaul kit. Put b&m shift kit in it. Its probably been about 10,000 miles since rebuild and I do run the truck pretty hard. It will cherp 2nd every time. Coming home the other nite I gradually lost forward gears. Still has reverse. I saw on a previous thread that it could b the forward clutch pack. Could they really be burned up that fast. Fluid stinks and has a lot of grey fiber in pan. Any suggestions? Thanks

    Advertisement
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2 (permalink)  
Old 12-01-2010, 08:32 PM
LATECH's Avatar
Hotrodders.com Moderator
 

Last journal entry: Motor - vator
Last photo:
Join Date: Jul 2010
Location: Northeast Pennsylvania
Posts: 5,436
Wiki Edits: 0

Thanks: 230
Thanked 296 Times in 275 Posts
Thats where I would look. At least the symptoms and the way it failed would lead me to look there first.
Reply With Quote Quick reply to this message

Recent Transmission - Rearend posts with photos

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Powerglide. Drives in Reverse, but not forward calclown Transmission - Rearend 3 06-11-2010 07:37 PM
my th350 popped out of reverse and will not engage strokedout Transmission - Rearend 4 09-07-2009 12:39 PM
1994 4l60e no forward or reverse cavy383 Transmission - Rearend 4 08-19-2009 06:03 PM
350 Trans Issue, Stalls engine in Reverse mseifried Transmission - Rearend 12 04-14-2009 02:52 PM
TH350 reverse issues DoubleVision Transmission - Rearend 2 12-08-2005 06:53 PM


All times are GMT -6. The time now is 02:17 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.