No juice,won't start- 348 chevy - Hot Rod Forum : Hotrodders Bulletin Board
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Electrical
User Name
Password
lost password?   |   register now

Reply
 
LinkBack Thread Tools
  #1 (permalink)  
Old 12-07-2012, 07:41 AM
bsa_bob's Avatar
Member
 
Last photo:
Join Date: Apr 2011
Location: britton mich
Posts: 346
Wiki Edits: 0

Thanks: 63
Thanked 2 Times in 2 Posts
No juice,won't start- 348 chevy

I have this kar hooked up to 12 volts,,,,,,it turns over fine, The wire looks small in dia; into the distributor; stock points type. Coil is wired right as far as the minus sign on the coil goes to the dist; + goes to 12 volt. I hooked up a switch to a new wire from the+post on the bat,to the + side of the coil. Then i turn the "key" inside the kar. i still don't get 12 volts. This old 60 chevy has set out in a woods for 9 years or so. It was said to have been driven in there, while it was running and just turned of. Divorces make guys do these things , The motor looks good, but the kar has been a home to two dead skunks, thousands of mice. It has had the seats totaly eaten away. Back to the kar. I figure maybe somebody wants this motor for restoration . the original turbo glide is still there .Anything you can do to point me in the right direction will be very graeful on my side bob s I have built hotrods all my life [long *** time]'but am starting to forget the many procedures it takes to get an engine running

    Advertisement
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2 (permalink)  
Old 12-07-2012, 10:17 AM
bondo's Avatar
Member
 
Last photo:
Join Date: Nov 2002
Location: Chaumont Bay N.Y.
Posts: 960
Wiki Edits: 0

Thanks: 7
Thanked 15 Times in 15 Posts
Ayuh,.... I'd start with filing, or better yet, changing, 'n settin' the Points...
Reply With Quote Quick reply to this message
  #3 (permalink)  
Old 12-07-2012, 12:00 PM
painted jester's Avatar
TAKE A KID TO A CAR SHOW
 

Last journal entry: mopar hump back
Last photo:
Join Date: Jan 2011
Location: Central Michigan
Age: 68
Posts: 1,837
Wiki Edits: 0

Thanks: 103
Thanked 292 Times in 240 Posts
You don't get 12 volts where? On the dash gauge, on volt meter at the resistor before the coil or at the points and condenser?

Is your distributor grounding good??? If its not grounding you will have no spark! an old car setting for years can lose the ground between the block and the distributor. It may have had a small ground wire at one time!
You need 2 wires to the + side of the coil one from the starter (The very small terminal for ignition) It supplies Juice to the coil as you turn it over and one from the ignition switch to the resistor! You have jumped a wire directly to the coil So you have bypassed that system! Is your battery reading a little over 12v ( a new battery will read a little over 13v) on a meter? If the coil wire is too small a gauge you could have a voltage drop!! Replace the condenser (there is no "going" bad with a condenser) Its either good or its bad(there is no in between). Without a good condenser it will have no spark! Does it have a condenser right on the + coil terminal The 60 chevys came with that it could be bad and grounding out (bleeding some electricity to ground)! Turn the key on and break the points open and closed manually when the points are off the actuating cam, you should see a small spark! if not See if there is voltage there with a test light when the points are open, if there is clean or replace them! If there's not track back through your wiring!

Jester

Last edited by painted jester; 12-07-2012 at 12:07 PM.
Reply With Quote Quick reply to this message
  #4 (permalink)  
Old 12-07-2012, 04:01 PM
bsa_bob's Avatar
Member
 
Last photo:
Join Date: Apr 2011
Location: britton mich
Posts: 346
Wiki Edits: 0

Thanks: 63
Thanked 2 Times in 2 Posts
348 problem

The dash lites come on perfect.There isn't a resistor on this car .you mean that chevy used on evrything back then? battery is new.the tiny small wire is disconnected ...i thought it was the after market tach wire.the condensor hasn't been checked.....i will to that next.Wouldn't 12 volts to the coil+from the bat post;. be the same thing? as hooking the wire to the starter main post then taking it over to the coil+
Reply With Quote Quick reply to this message
  #5 (permalink)  
Old 12-07-2012, 04:37 PM
painted jester's Avatar
TAKE A KID TO A CAR SHOW
 

Last journal entry: mopar hump back
Last photo:
Join Date: Jan 2011
Location: Central Michigan
Age: 68
Posts: 1,837
Wiki Edits: 0

Thanks: 103
Thanked 292 Times in 240 Posts
Quote:
Originally Posted by bsa_bob View Post
The dash lites come on perfect.There isn't a resistor on this car .you mean that chevy used on evrything back then? battery is new.the tiny small wire is disconnected ...i thought it was the after market tach wire.the condensor hasn't been checked.....i will to that next.Wouldn't 12 volts to the coil+from the bat post;. be the same thing? as hooking the wire to the starter main post then taking it over to the coil+

It will be close to the same there is a small drop. Some coils have a built in resistance. you can have a voltage drop somewhere any where there is any resistance it can drop your voltage! whats the voltage when you test the battery terminals? Disconnect the coil+ and test from the battery- to the end of the wire. Then hook it back up to the coil+ and test. Whats your readings on the volt meter?

There's a small wire that hooks to the + of the coil on the 60s chevys that has a braided covering that is white in color (when new LOL) it could be dark brown from dirt and oil now> That wire is a the built in resister! If its gone or by passed you need a resistor with an ohm rating for the coil, some coils don't need a resistor it depends on what coil is installed! if you hook up the braided wire and install another resistor it will not run right! If you don't run a resistor on a coil that doen't need one it wont run right ETC. Your condenser has to be the right impedance or it will burn up your points or they will pit on one side and build up on the other and wont run right! Years ago I liked Blue Streak points they lasted forever but they merged and now they are Napa or Echlin! Dont by Jap. or Chin. the quality is terrible


Jester
Reply With Quote Quick reply to this message
  #6 (permalink)  
Old 12-07-2012, 08:12 PM
EOD Guy's Avatar
Registered User
 
Last photo:
Join Date: Aug 2010
Location: Alabama
Posts: 2,055
Wiki Edits: 0

Thanks: 1
Thanked 131 Times in 122 Posts
12v from the battery to the + post on the coil wil bypass the ing system etc...... but as mentioned above you will burn out the coil in short order with out the resistor. You can get a external ballast resistor from NAPA that fits the old MOPAR cars.
Reply With Quote Quick reply to this message
  #7 (permalink)  
Old 12-07-2012, 09:09 PM
painted jester's Avatar
TAKE A KID TO A CAR SHOW
 

Last journal entry: mopar hump back
Last photo:
Join Date: Jan 2011
Location: Central Michigan
Age: 68
Posts: 1,837
Wiki Edits: 0

Thanks: 103
Thanked 292 Times in 240 Posts
Quote:
Originally Posted by painted jester View Post
It will be close to the same there is a small drop. Some coils have a built in resistance. you can have a voltage drop somewhere any where there is any resistance it can drop your voltage! whats the voltage when you test the battery terminals? Disconnect the coil+ and test from the battery- to the end of the wire. Then hook it back up to the coil+ and test. Whats your readings on the volt meter?

There's a small wire that hooks to the + of the coil on the 60s chevys that has a braided covering that is white in color (when new LOL) it could be dark brown from dirt and oil now> That wire is a the built in resister! If its gone or by passed you need a resistor with an ohm rating for the coil, some coils don't need a resistor it depends on what coil is installed! if you hook up the braided wire and install another resistor it will not run right!
--------------------------If you don't run a resistor on a coil that need one it wont run right--------------------
ETC. Your condenser has to be the right impedance or it will burn up your points or they will pit on one side and build up on the other and wont run right! Years ago I liked Blue Streak points they lasted forever but they merged and now they are Napa or Echlin! Dont by Jap. or Chin. the quality is terrible


Jester
I missed typed these are the correctionsIm getting old LOL

if you dont run a resister on a coil that needs one it wont run right
if you run a resistor on a coil that doesn't need one it wont run right ETC.
Reply With Quote Quick reply to this message
  #8 (permalink)  
Old 12-08-2012, 11:28 AM
bsa_bob's Avatar
Member
 
Last photo:
Join Date: Apr 2011
Location: britton mich
Posts: 346
Wiki Edits: 0

Thanks: 63
Thanked 2 Times in 2 Posts
Quote:
Originally Posted by painted jester View Post
I missed typed these are the correctionsIm getting old LOL

if you dont run a resister on a coil that needs one it wont run right
if you run a resistor on a coil that doesn't need one it wont run right ETC.

I'm going downtown and buy a Remote start switch Where would you hook one up. standing in front looking at the motor? I could check spark plug fire on each cylinder among other things.I took the dis; cap off it looks like new .the points have been sealed inside, so they look pretty good[far as newness is concerned]

The condenser is still shiney.And i find myself not being able to lay on the engine to work on the distributor,.............do to the distance!.......... clear to the back.of the engine bay.I had forgotten since the two i had in the 60s, how far back the engine sets in these 60s. I can lay there but i won't be able to get back up.......and shes baking several different kinds of Christmas cookies. Can't disturb her you know how that goes . any clues appreciated

bob
Reply With Quote Quick reply to this message
  #9 (permalink)  
Old 12-08-2012, 11:49 AM
painted jester's Avatar
TAKE A KID TO A CAR SHOW
 

Last journal entry: mopar hump back
Last photo:
Join Date: Jan 2011
Location: Central Michigan
Age: 68
Posts: 1,837
Wiki Edits: 0

Thanks: 103
Thanked 292 Times in 240 Posts
Bob How old are you ? I was president of a couple of car clubs in the bottom of the mit! Wyandotte President of the "Igniters" 50 years ago ( all dead now) Im the last member alive , A member of The "Piston pushers" Detroit and suburbs, A member of The "Motor state street rods" Detroit and suburbs, President of the "Taylor Area" street rods, And president of the reformed Igniters in Gaylord Michigan I moved and left that club. I'm not in a club now Their too structured and too many rules any more!


Jester
Reply With Quote Quick reply to this message
  #10 (permalink)  
Old 12-08-2012, 12:44 PM
bsa_bob's Avatar
Member
 
Last photo:
Join Date: Apr 2011
Location: britton mich
Posts: 346
Wiki Edits: 0

Thanks: 63
Thanked 2 Times in 2 Posts
Quote:
Originally Posted by painted jester View Post
Bob How old are you ? I was president of a couple of car clubs in the bottom of the mit! Wyandotte President of the "Igniters" 50 years ago ( all dead now) Im the last member alive , A member of The "Piston pushers" Detroit and suburbs, A member of The "Motor state street rods" Detroit and suburbs, President of the "Taylor Area" street rods, And president of the reformed Igniters in Gaylord Michigan I moved and left that club. I'm not in a club now Their too structured and too many rules any more!


Jester
Wait a minute!! You are the big guy from taylor. Does the p/s on everything.I started the "ypsi area street rods 35 years ago.i'm the only original member left. i know bob nash,dick confer, don carnavelle. I was freinds with paul klein-------I live in tecumseh mich, now you aren't Mike Gados?? bob scharp 32 ford sedan, now have a steel 3-window and a full kustom 50 merc
Reply With Quote Quick reply to this message
  #11 (permalink)  
Old 12-08-2012, 02:25 PM
painted jester's Avatar
TAKE A KID TO A CAR SHOW
 

Last journal entry: mopar hump back
Last photo:
Join Date: Jan 2011
Location: Central Michigan
Age: 68
Posts: 1,837
Wiki Edits: 0

Thanks: 103
Thanked 292 Times in 240 Posts
Quote:
Originally Posted by bsa_bob View Post
Wait a minute!! You are the big guy from taylor. Does the p/s on everything.I started the "ypsi area street rods 35 years ago.i'm the only original member left. i know bob nash,dick confer, don carnavelle. I was freinds with paul klein-------I live in tecumseh mich, now you aren't Mike Gados?? bob scharp 32 ford sedan, now have a steel 3-window and a full kustom 50 merc
Its me Chris Towery: I Know you I had the 38 Plymouth with the cross ram 409 and 4 speed used to run B gas! Small world I know all those guys Its bad if your the last of a clubs members Post a pic on the show your mug thread

Look in my journal !!!!



Chris
Reply With Quote Quick reply to this message
The Following User Says Thank You to painted jester For This Useful Post:
bsa_bob (12-08-2012)
  #12 (permalink)  
Old 12-08-2012, 02:45 PM
bsa_bob's Avatar
Member
 
Last photo:
Join Date: Apr 2011
Location: britton mich
Posts: 346
Wiki Edits: 0

Thanks: 63
Thanked 2 Times in 2 Posts
348 won't start

[QUOTE=painted jester;1620529]Its me Chris Towery: I Know you I had the 38 Plymouth with the cross ram 409 and 4 speed used to run B gas! Small world I know all those guys Its bad if your the last of a clubs members Post a pic on the show your mug thread

here is somemore stuff Chris

I remember your car! It been long time since i've seen those guys for the most part. Whatever happened to ron morgan[suspended animation" his car.and diid they ever catch up with evertt rezindes prolly spelled wrong; i remember him driving the cranberry T , he called it. I used to see charlie rose around in the summers in his black 32 ford cpe.I saw him a few years ago at the ididit seminars and the ididit car show out by me. i'll look at your journal.

One more thing today.I now have 12 volt [thru my test lite] to the+ side of the coil. Still no fire at the plugs.Do you think its the points and condenser jester? bob s ps it is a small world as the years go by. And it keeps gettin smaller..as i told my wife til they put you in the ground........i still want to do a 55 chevy i'd better get at it

sorry one more question i built a BLack 57 h/t in the late 70s, jumbo did the interior remember him?It had a 4- speed 350 chevelle buckets and console i Sold this kar to a guy in the asphalt business around you somewhere. I was told by a guy from chicago that knew him,He said the guy had torn off the passenger side then put it in a garage..wheres its been since three weeks after i sold it.in the 70s. ring a "BEll" at all? i have tried and still trying to get it back see ya Chris

Man have you been busy Chris....what a great journal. i kept pics going but not to the extent you did..its kool man. bob

Last edited by bsa_bob; 12-08-2012 at 02:55 PM.
Reply With Quote Quick reply to this message
  #13 (permalink)  
Old 12-08-2012, 06:37 PM
painted jester's Avatar
TAKE A KID TO A CAR SHOW
 

Last journal entry: mopar hump back
Last photo:
Join Date: Jan 2011
Location: Central Michigan
Age: 68
Posts: 1,837
Wiki Edits: 0

Thanks: 103
Thanked 292 Times in 240 Posts
Bob I live outside of Clare and Everett in gods country with the shooters and beer drinken bible thumpers that think the word ends on the 21st LOL


He was Everett Rezendes, 1929 Ford, The Cranberry Delivery! He took all the credit on the Cranberry Delivery when he won Riddler Award! Joe Zambeck, Myself and about 20 others helped on that car! I thought he was my friend! His only friend was his money!! He was Busted and sued for stealing from Ford motor company R&D department (the touch controls and other things) I don't know if he went to jail for it though! I was supposed to testify but he pled out!I always thought they should have pulled his trophy but they didn't! He never put cooler lines on that car (Shows only car LOL) and when it was driven the first time it blew the whole trans out of it (on the ground)LOL
I had pictures of it when we worked on it but they were Polaroids and faded terribly I threw them out! It was something we were all proud of ) Till the scandal hit!



"Packy" lives up here by me! he was in the Piston Pushers and Taylor Area Street Rods His lungs are shot from asbestos! I don't know where Morgan is. I saw Rose a while back on the U.S. 27 tour. The "I did it" car and truck come up here to the weekend Coleman Show, Burn outs Fri. night and the show till Sunday afternoon! Its one of the good shows in Micigan!

I haven't seen Jumbo since '79 when I had cancer he came to see me before I died LOL I was diagnosed terminal! I beat the Devil though and Im still cruisen, We used to stop in at his home when cruising Telegraph when Woodward was getting tough to cruise! I remember your car! Hope you get it back one day! I can't help you though! The Dodge Hump back, Packy's "The Pack Rat" came in 3rd or 4th against the Cranberry I repainted and restored it a couple of years ago its in my Journal! It was hell redoing his mural it was hand painted years ago!

You didn't answer how old you are now? I had cancer a couple of more times again and had to sell the Plymouth after 39 years to pay medical bills
and picked up the Vett for 500 dollars it was t boned on both sides LOL but the frame was untouched Built it back with no Body parts just fiber & resin all I need now is door panels and paint but I still have fun driving it unfinnished and Im working on a 79 Camaro for the wife.


When your points are open do you have juice going to the terminal of the points from the coil? (when the points close and ground, the coil should throw a spark) if the points don't ground there will be no spark so yes it is very possible you need good points! So it could be a bad coil or condenser (unless you changed them) Or points or your dist. is not grounding! You can check the dist. ground easy hook the test light to power and touch the dist. body if it lights you have a good Dist. ground! Is that an old coil? If the plate the points are screwed to doesn't have a good ground to the dist. it wont let the points fire You can run a ground wire from the point plate screw to the main body of the dist. many distributors have that. If the engine block isn't grounding good it wont get spark, If the plugs aren't grounding to the block they wont spark!Did you check or change the plugs?

Did you check and clean all your grounds! How many years did your car set and was it out doors?

Your old friend Chris
Reply With Quote Quick reply to this message
  #14 (permalink)  
Old 12-08-2012, 07:55 PM
bsa_bob's Avatar
Member
 
Last photo:
Join Date: Apr 2011
Location: britton mich
Posts: 346
Wiki Edits: 0

Thanks: 63
Thanked 2 Times in 2 Posts
Quote:
Originally Posted by painted jester View Post
Bob I live outside of Clare and Everett in gods country with the shooters and beer drinken bible thumpers that think the word ends on the 21st LOL


He was Everett Rezendes, 1929 Ford, The Cranberry Delivery! He took all the credit on the Cranberry Delivery when he won Riddler Award! Joe Zambeck, Myself and about 20 others helped on that car! I thought he was my friend! His only friend was his money!! He was Busted and sued for stealing from Ford motor company R&D department (the touch controls and other things) I don't know if he went to jail for it though! I was supposed to testify but he pled out!I always thought they should have pulled his trophy but they didn't! He never put cooler lines on that car (Shows only car LOL) and when it was driven the first time it blew the whole trans out of it (on the ground)LOL
I had pictures of it when we worked on it but they were Polaroids and faded terribly I threw them out! It was something we were all proud of ) Till the scandal hit!



"Packy" lives up here by me! he was in the Piston Pushers and Taylor Area Street Rods His lungs are shot from asbestos! I don't know where Morgan is. I saw Rose a while back on the U.S. 27 tour. The "I did it" car and truck come up here to the weekend Coleman Show, Burn outs Fri. night and the show till Sunday afternoon! Its one of the good shows in Micigan!

I haven't seen Jumbo since '79 when I had cancer he came to see me before I died LOL I was diagnosed terminal! I beat the Devil though and Im still cruisen, We used to stop in at his home when cruising Telegraph when Woodward was getting tough to cruise! I remember your car! Hope you get it back one day! I can't help you though! The Dodge Hump back, Packy's "The Pack Rat" came in 3rd or 4th against the Cranberry I repainted and restored it a couple of years ago its in my Journal! It was hell redoing his mural it was hand painted years ago!

You didn't answer how old you are now? I had cancer a couple of more times again and had to sell the Plymouth after 39 years to pay medical bills
and picked up the Vett for 500 dollars it was t boned on both sides LOL but the frame was untouched Built it back with no Body parts just fiber & resin all I need now is door panels and paint but I still have fun driving it unfinnished and Im working on a 79 Camaro for the wife.


When your points are open do you have juice going to the terminal of the points from the coil? (when the points close and ground, the coil should throw a spark) if the points don't ground there will be no spark so yes it is very possible you need good points! So it could be a bad coil or condenser (unless you changed them) Or points or your dist. is not grounding! You can check the dist. ground easy hook the test light to power and touch the dist. body if it lights you have a good Dist. ground! Is that an old coil? If the plate the points are screwed to doesn't have a good ground to the dist. it wont let the points fire You can run a ground wire from the point plate screw to the main body of the dist. many distributors have that. If the engine block isn't grounding good it wont get spark, If the plugs aren't grounding to the block they wont spark!Did you check or change the plugs?

Did you check and clean all your grounds! How many years did your car set and was it out doors?

Your old friend Chris
I am 68 years old this year and inprtty good shape, 34 operations on worn out parts in ME. rods in my back steel hip stell replacement o=piece in my right elbow . Quit smokin after 39 years......lucky to be alive i'd say i'll check those latest recomendatinos tomorrow.
This 60 set o/s for 8or 9 years in back of a building by the prison in ypsilanti twp

your loe ..new founf friend bob scharp ias jumbo still in business.?I see Teddy Z quite often in the summer shows around here. take care we will talk again PS Chris now that you mention it .it comes back to me. Rezendes hid that red delivery for awhile. Do you remember the couple who were killed hauling the "other" red delivery built around the same time. It rolled over and down a hill in tenn. They were pulling an enclosed trailer at the time. i remember being told. the transvan and the couple were killed, and the trailer was damaged..but the A -model came thru untouched. thats all i can remember, except the couple owned their own body shop. Nice people they were.i know there names can't think of them now. Chris.My memory is a bit cloudy till i see a sweet hotrod,or kustom kar, and it all comes back to me how great they are. as..................................... usuall typos are free bob s
Reply With Quote Quick reply to this message
  #15 (permalink)  
Old 12-08-2012, 09:06 PM
painted jester's Avatar
TAKE A KID TO A CAR SHOW
 

Last journal entry: mopar hump back
Last photo:
Join Date: Jan 2011
Location: Central Michigan
Age: 68
Posts: 1,837
Wiki Edits: 0

Thanks: 103
Thanked 292 Times in 240 Posts
Bob!

We're ageing fast LOL yesterday it was 1969 LOL! My memory does that too!
I'll be typing on here and forget what I was Going to say and I'll wake up in the middle of the night and remember!!!!

My shoulders have been replaced 7 surgery's they were bone to bone and the tendons tore loose and the muscles rolled down to my elbows! and I crushed my lower 4 vertebra 7 years ago! But actually I feel good and in pretty good shape Just I walk slower now! But Im still awnry as hellI quit drinking but love a good cigar (about 3 El Producto bouquets a day) If I can find em up here

I went by Jumbo's when I was at the Woodward Detroit cruise He was long gone and I asked about him and no one knew where he moved to I heard about the wreck I didn't know they were killed but I did hear about the car being untouched!

The Cranberry Delivery was hidden by Everett because Ford wanted all the experimental stuff back! they had a court order! It was developed for a future prototype show car Ford was developing! I saw the car in St. Ignace at the show and the new owners did not know the story about the car! The gauges & touch control's and electronics were gone! It had standard gauges and switches & wiring! I have no Idea what happened to him I heard he left the Detroit area in shame!

You can check if your plugs are grounding with a test light hooked to + and touching the plug bases with the probe if it lights the block and plugs are grounding.

Good luck tomorrow I hope it starts, That wouldn't happen to be a 6 pack 348 and 4 speed would it?


Jester
Reply With Quote Quick reply to this message

Recent Electrical posts with photos

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
57 chevy won't start cbxmotor6 Electrical 7 04-28-2011 04:28 PM
EFI Chevy won't start. Why? willys36@aol.com Engine 5 10-18-2009 07:35 PM
chevy 350 won't start Troy Smedley Engine 2 03-23-2007 05:21 AM
96 Chevy p/w won't start, help please JustMeTMC Electrical 4 11-29-2004 10:06 PM
86 chevy won't start 56Thunder Engine 15 08-19-2004 03:11 PM


All times are GMT -6. The time now is 01:37 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.