Hot Rod Forum : Hotrodders Bulletin Board

Hot Rod Forum : Hotrodders Bulletin Board (http://www.hotrodders.com/forum/)
-   Electrical (http://www.hotrodders.com/forum/electrical/)
-   -   No power to ignition 93 Mercury topaz (http://www.hotrodders.com/forum/no-power-ignition-93-mercury-topaz-223031.html)

JohnMercury 08-18-2012 01:24 PM

No power to ignition 93 Mercury topaz
 
I forgot to disconnect the battery cable to the -ve terminal before I removed the ignition lock cylinder and ignition switch. I replaced them with new parts and now when I turn the key to ignition ON, none of the lights on the instrument panel come on, can't hear the fuel pump kick in. Completely dead with no power to ignition. Tried to jump start from another car battery, but still no lights come on. Any suggestions as to few things I can check and fix myself before I take it to a mechanics. Thank you.

LATECH 08-18-2012 03:23 PM

probbly a missing mechanical link between the lock cyl and the switch.
Double check your work.Compare parts, look for missing link.

EOD Guy 08-18-2012 09:02 PM

X2 with LA, there should be a lever that connects to a rod, rod rund down the column to the actual switch...... somethings popped off, should be an easy fix


All times are GMT -6. The time now is 01:43 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.