No start and no compression - Hot Rod Forum : Hotrodders Bulletin Board
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Engine
User Name
Password
lost password?   |   register now

Reply
 
LinkBack Thread Tools
  #1 (permalink)  
Old 05-29-2013, 10:13 PM
Registered User
 
Join Date: Nov 2009
Location: Rockford,Iowa
Age: 20
Posts: 77
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
No start and no compression

engine got hot trying to limp it back home then slowly starting loosing power then shot off completely and wouldn't start, did some tests no compression at all on all cylinders, pressure coming out of oil fill cap when turned over drained oil too and hardly any oil came out so it burned some oil with it

    Advertisement
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2 (permalink)  
Old 05-29-2013, 10:15 PM
vinniekq2's Avatar
Registered User
 
Join Date: Jun 2012
Location: BC,Canada
Age: 56
Posts: 7,450
Wiki Edits: 0

Thanks: 292
Thanked 709 Times in 684 Posts
what kind of car? timing belt?
Reply With Quote Quick reply to this message
  #3 (permalink)  
Old 05-29-2013, 10:19 PM
Registered User
 
Join Date: Nov 2009
Location: Rockford,Iowa
Age: 20
Posts: 77
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
Quote:
Originally Posted by vinniekq2 View Post
what kind of car? timing belt?
99 chevy cavalier ha. 2.4 twin cam
Reply With Quote Quick reply to this message
  #4 (permalink)  
Old 05-29-2013, 10:54 PM
S10 Racer's Avatar
http://www.warsprints.com
 

Last journal entry: W.A.R. (Wingless Auto Racing) Sprint Car Racing
Last photo:
Join Date: Nov 2007
Location: At The Dirt Tracks
Age: 55
Posts: 1,870
Wiki Edits: 0

Thanks: 3
Thanked 57 Times in 52 Posts
My experience with the Cavalier when they get hot is that the head cracks. Being a twin cam, most are "0" tolerance motors meaning if the timing belt broke, you may have some serious problems with bent valves.
Reply With Quote Quick reply to this message
  #5 (permalink)  
Old 05-29-2013, 11:08 PM
Registered User
 
Join Date: Nov 2009
Location: Rockford,Iowa
Age: 20
Posts: 77
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
Quote:
Originally Posted by S10 Racer View Post
My experience with the Cavalier when they get hot is that the head cracks. Being a twin cam, most are "0" tolerance motors meaning if the timing belt broke, you may have some serious problems with bent valves.
before it shut down completely at idle it would make a ticking sound but higher rpms It would go away.
Reply With Quote Quick reply to this message

Recent Engine posts with photos

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
sbc 350 will start run rough for a few seconds die and wont start fuel-junky Engine 11 01-08-2013 11:30 AM
compression ratio compared to compression PSI squids1 Engine 14 12-28-2010 11:36 PM
Easy cold start, hard hot start dedub Engine 34 08-13-2008 05:21 PM
change modular car will start shut off and won't start back up Ramman Engine 1 11-26-2004 08:20 PM
Installed New Cam, CAR WONT Start/no Compression? sum87mustang Engine 4 10-27-2003 07:52 AM


All times are GMT -6. The time now is 10:38 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.