no turn signals - Hot Rod Forum : Hotrodders Bulletin Board
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Electrical
User Name
Password
lost password?   |   register now

Reply
 
LinkBack Thread Tools
  #1 (permalink)  
Old 12-14-2005, 05:35 PM
Registered User
 
Join Date: Dec 2005
Location: omaha nebraska
Posts: 6
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
no turn signals

Hi
Need help in finding out why I have no turn signals.I've got a 1971 ford f-250 pickup that recently has no turn signals. I've check the fuze and it's good. the bulbs are all new.I've got parking lights but when I flip on the turn signal lever I get nothing.The flasher is new and works in my other cars.Could it be the turn signal switch it self ? How do I go about checking to see if the switch is bad? Thanks Alot. ED

    Advertisement
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2 (permalink)  
Old 12-14-2005, 05:57 PM
BOBCRMAN@aol.com's Avatar
Member
 
Last photo:
Join Date: May 2002
Location: Holly, michigan
Posts: 8,084
Wiki Edits: 0

Thanks: 23
Thanked 257 Times in 241 Posts
Check for bad grounds at the light
Reply With Quote Quick reply to this message
  #3 (permalink)  
Old 12-14-2005, 06:55 PM
302 Z28's Avatar  
Last photo:
Join Date: May 2003
Location: North Texas
Posts: 10,837
Wiki Edits: 0

Thanks: 1
Thanked 86 Times in 73 Posts
That year Ford is notorious for bad turn signal switches. I can't tell you how many I replaced when I was in the business. I think I still have a test switch in my tool box somewhere.

Vince
Reply With Quote Quick reply to this message
  #4 (permalink)  
Old 12-14-2005, 07:11 PM
Rob Keller's Avatar
AKA:"SLOWRIDE66"take it easy!
 
Last wiki edit: How to post pictures on a forum
Last journal entry: 85 Suburban
Last photo:
Join Date: May 2004
Location: Central Florida U.S.A.
Age: 48
Posts: 4,297
Wiki Edits: 38

Thanks: 0
Thanked 1 Time in 1 Post
do the brake lights burn?
how 'bout the 4 way flashers?
brake lights should be independent of turn single circuit


my 79 f250 's tail light sockets made that problem for me few years ago make sure to get the SHORT replacement sockets or the bulb will come through the lens

SR66
__________________
"SlowRide66"

"Illegitimis non carborundum"
Don't let the bastards grind you down!

Crankshaft Coalition Master List of Hotrodding Forums
Reply With Quote Quick reply to this message
  #5 (permalink)  
Old 12-15-2005, 08:15 AM
Registered User
 
Join Date: Dec 2005
Location: omaha nebraska
Posts: 6
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
no turn signals

Quote:
Originally Posted by 302/Z28
That year Ford is notorious for bad turn signal switches. I can't tell you how many I replaced when I was in the business. I think I still have a test switch in my tool box somewhere.

Vince
Hi Vinny
Fasteddie here on the no turn signals on my 1971 ford F-250.I've got emergency flashers ,but when it comes to the left and right turn signals absolutely nothing.How does a guy go about testing the switch itself?As far as the other lights they all work. Brake lights , tail lights, parking lights,head lights.Sounds to me like its the switch .What about you? Thanks for your advice. Fast Eddie
Reply With Quote Quick reply to this message
  #6 (permalink)  
Old 12-15-2005, 09:30 AM
Rob Keller's Avatar
AKA:"SLOWRIDE66"take it easy!
 
Last wiki edit: How to post pictures on a forum
Last journal entry: 85 Suburban
Last photo:
Join Date: May 2004
Location: Central Florida U.S.A.
Age: 48
Posts: 4,297
Wiki Edits: 38

Thanks: 0
Thanked 1 Time in 1 Post
http://www.powerprobe.com/powerprobeproduct.html

this is a great tool for tracking power problems

Its a process of elimination

disconnect the battery and you will need a teat light and a jumper wire ( be careful with the jumper wire that you dont short something out )

there should be a plug around the steering column (maybe two)
disconnect it there and try the systems from there you should be able to get wiring schematics from here

http://www.fordification.com/siteindex.htm

& here

http://www.fordification.com/wiring.htm

if you can pick up a sued one from a bone yard(one that you know is working) you would be able to just plug it in .

BUT...

be advised even though it looks the same make sure all the wires go into the plug exactly like the old one .

if you find that the switch is bad then theres more to do ...

taking off the steering wheel and so forth...

let us know what you figure out

SR66
__________________
"SlowRide66"

"Illegitimis non carborundum"
Don't let the bastards grind you down!

Crankshaft Coalition Master List of Hotrodding Forums
Reply With Quote Quick reply to this message
  #7 (permalink)  
Old 12-15-2005, 09:38 AM
Registered User
 
Last photo:
Join Date: Dec 2005
Location: Charleston, SC
Posts: 65
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
switch

Sounds to me that the switch within the column is probably bad. This is from my experience with my '69 Cougar. I had similar problem. Granted the sequential taillights on my car are more complicated-- but I had the same symptoms.

A lot of times the contacts get corroded or melted/ wires get melted. A repro replacement for Mustangs and Cougars of this era cost around $80. Not sure if the same part is used in the F150 column. Assuming ford used the same in-column style switch, to replace the switch, you must pull the steering wheel.

But Before getting a new switch, I would also check the grounds in the turn signals themselves. They wont work if there isnt a good ground connection.
Reply With Quote Quick reply to this message
  #8 (permalink)  
Old 12-15-2005, 08:11 PM
docvette's Avatar
Hotrodders.com Moderator
 
Last wiki edit: Rebuild an alternator Last photo:
Join Date: Mar 2004
Location: Lafayette, california
Age: 62
Posts: 7,362
Wiki Edits: 12

Thanks: 0
Thanked 6 Times in 3 Posts
Doc here,



Check the 25 amp Fuse #6 first, Then check or just replace the flasher. Make sure you are dealing with the regular flasher and not the 4 way (which we know works) when testing..there are 2...

If the 4 ways, Brake and other lights are working, chances are you are dealing with a bad flasher or bad fuse as all run through the same switch...but if these check out then you will have to replace the switch.

Doc
__________________
Aftermarket Solutions
Electronic & Electrical
Innovations
Reply With Quote Quick reply to this message
  #9 (permalink)  
Old 12-16-2005, 09:25 AM
Registered User
 
Join Date: Dec 2005
Location: omaha nebraska
Posts: 6
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
DOC
Fast 1 here on the no turn signal lights.Every thing seems to check out ,the flasher is new the 14amp fuze in the fuze box for the turn signals is good,the bulbs are all new.I've got parking lights , brake lights ,tail lights backup lights and head lights but still no turn signal lights.One question for you.When I have the brake lights on and pull up or down on the turn signal arm the brake light goes out on one side or the other side depending on which way I pull up or down on the turn signal lever.Whats causing this to happen?Could it be the switch itself?With the steering wheel off is there any way to check out the switch with a test light?All your help is appreciated.Thanks again. Fast 1
Reply With Quote Quick reply to this message
  #10 (permalink)  
Old 12-16-2005, 04:04 PM
302 Z28's Avatar  
Last photo:
Join Date: May 2003
Location: North Texas
Posts: 10,837
Wiki Edits: 0

Thanks: 1
Thanked 86 Times in 73 Posts
Replace the switch and be done with it.

Vince
Reply With Quote Quick reply to this message

Recent Electrical posts with photos

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Turn signals won't shut off after turning! 1meancuda Electrical 2 09-01-2004 01:48 PM
dash lights and turn signals - again SteveMach1 Electrical 2 12-13-2003 10:22 PM
Adding turn signals to '53 Ford P/U first timer Electrical 4 12-04-2003 04:37 AM
Wiring Tail Lights & Turn Signals horvath Electrical 15 04-30-2003 05:04 AM
turn signals impala dreaming Electrical 5 02-24-2003 06:29 PM


All times are GMT -6. The time now is 05:35 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.