Noisy dry sump pump - Hot Rod Forum : Hotrodders Bulletin Board
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Engine
User Name
Password
lost password?   |   register now

Reply
 
LinkBack Thread Tools
  #1 (permalink)  
Old 09-08-2002, 12:02 AM
Registered User
 
Join Date: Sep 2002
Location: UK
Posts: 1
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
Post Noisy dry sump pump

My Moroso dry sump pump has started to make a really loud buzzing noise at about 4000rpm. The oil pressure reaches about 85psi, I assume the relief value is set at the factory setting of 50psi. The valve looks in good order. Has anybody experienced this before? The pump is fitted to a blown Chevy small block.
Any help would be appreciated

Julian.

    Advertisement
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2 (permalink)  
Old 09-08-2002, 08:28 AM
4 Jaw Chuck's Avatar
Hotrodders.com Moderator
 
Last photo:
Join Date: Mar 2002
Location: Manitoba, Canada
Age: 46
Posts: 4,974
Wiki Edits: 0

Thanks: 2
Thanked 89 Times in 72 Posts
Post

Are the mounts and belt tight? Extreme vibration can "fool" the relief vavle into opening at a higher pressure. Since the opening pressure is so high have you thought about replacing it? Is it adjustable?
__________________
Outlawed tunes from outlawed pipes
Reply With Quote Quick reply to this message
  #3 (permalink)  
Old 09-08-2002, 10:52 AM
deuce_454's Avatar
Member
 
Last photo:
Join Date: May 2002
Location: Copenhagen, Denmark
Age: 39
Posts: 1,000
Wiki Edits: 0

Thanks: 0
Thanked 1 Time in 1 Post
Post

there is nothing in a hydraulic relief valve/ball system that will make a noise loud enough to be audible when boltet to a blown small block, What you are propably hearing is the pump cavitating/pumping small gas boubles. my bet is that the suction side is either restricted in some way causing cavitation, or the hoze from where you are sucking the oil is above fluid level at the given rpm..

thats just my 0.02$ worth

[ September 08, 2002: Message edited by: deuce_454 ]</p>
Reply With Quote Quick reply to this message

Recent Engine posts with photos

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -6. The time now is 04:53 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.