not a hot rod, 96 jeep cheroke laredo. trans problem - Hot Rod Forum : Hotrodders Bulletin Board
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Transmission - Rearend
User Name
Password
lost password?   |   register now

Reply
 
LinkBack Thread Tools
  #1 (permalink)  
Old 07-26-2007, 05:00 PM
Registered User
 
Last photo:
Join Date: Mar 2006
Location: ocklawaha,Fl
Age: 25
Posts: 223
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
not a hot rod, 96 jeep cheroke laredo. trans problem

i have a 96 jeep grand cheroke laredo.. trans does not shift into overdrive,, did before,, and has once in a great while.. and stays in first sometimes for too long.. say like 6 sec.. goes up to 4,000 rpm sometimes befor it shifts..

    Advertisement
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2 (permalink)  
Old 07-29-2007, 07:45 PM
Registered User
 
Join Date: Mar 2007
Location: South Dakota
Posts: 11
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
your kick down is messed up.
Reply With Quote Quick reply to this message

Recent Transmission - Rearend posts with photos

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
stroke to rod ratio jacobm99 Engine 28 12-16-2013 06:46 PM
Problem with new rod bolts... 11echo Engine 8 05-13-2004 03:07 PM
vortec 96 problem belgiumastro Electrical 7 04-17-2004 08:00 AM
problem with hot rod search klassik100 Hotrodders Site Suggestions and Help 2 03-08-2004 03:58 PM
longest rods in std deck 454 bbc?? deuce_454 Engine 11 01-30-2004 11:06 AM


All times are GMT -6. The time now is 10:33 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.