Hot Rod Forum : Hotrodders Bulletin Board - View Single Post - Not really a tech post but a progress post 68 c-10
View Single Post
  #4 (permalink)  
Old 03-06-2006, 07:36 PM
Zumo Zumo is offline
Registered User
 
Last photo:
Join Date: Sep 2004
Location: Waxahachie, TX
Age: 40
Posts: 17
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
1st pic is the motor.

2nd pic pic is my new Urethane mounts I picked up from Summit.

3rd pic are the "Race" mufflers I got from Summit also. I have now I dea what they sound like but at this point I figure anything is better that my single glasspack I was running.

4th pic is my Tach, also from Summit.

5th is the box of parts I am going to have vatted so I can repaint everything. The engine is going to be red and I am going to use stock valve covers. I would love to have some finned Edlebrock covers but these will have to do for now. I have some chrome "dress up kit" valve covers that were on there before but I am going to sell those. I am also going to get another air cleaner as well.
Attached Images
Attached Thumbnails
Click image for larger version

Name:	DSC05905.jpg
Views:	49
Size:	40.3 KB
ID:	10553   Click image for larger version

Name:	DSC05913.jpg
Views:	43
Size:	30.7 KB
ID:	10554   Click image for larger version

Name:	DSC05904.jpg
Views:	49
Size:	25.4 KB
ID:	10555   Click image for larger version

Name:	DSC05911.jpg
Views:	51
Size:	39.9 KB
ID:	10556   Click image for larger version

Name:	DSC05906.jpg
Views:	62
Size:	46.3 KB
ID:	10557  

Reply With Quote