Oil leak - Hot Rod Forum : Hotrodders Bulletin Board
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Engine
User Name
Password
lost password?   |   register now

Reply
 
LinkBack Thread Tools
  #1 (permalink)  
Old 09-18-2006, 08:34 AM
fat40's Avatar
Registered User
 
Last photo:
Join Date: Dec 2005
Location: indianapolis , In
Age: 76
Posts: 106
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
Oil leak

Guys I have a oil leak at the seal in the timing cover, I have pete Jackson gear drive and was wondering if any of you running them have had any leaks, mine leak comes and goes . I am in the process of changing the seal. My harmonic balancer is new . It did not leak on the test stand or when I installed the motor, it has just started . I have 1000 miles on engine.

FAT40

    Advertisement
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2 (permalink)  
Old 09-21-2006, 12:30 PM
wrnchmaster's Avatar
Registered User
 
Join Date: Jul 2006
Location: port chester, ny
Posts: 58
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
did you re-torque all the bolts after break i in??
Reply With Quote Quick reply to this message
  #3 (permalink)  
Old 09-21-2006, 06:59 PM
Registered User
 
Join Date: Dec 2004
Location: San Jose Ca
Age: 62
Posts: 472
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
oil leak

Are you sure the leak is the timing cover and not the bolt hole on the front pass bottom of engine that is not sealed. This the one the pushrod for the fuel pump passes thru. Also you can purchase dye for oil and put a blacklight on it to help find leak.
Reply With Quote Quick reply to this message
  #4 (permalink)  
Old 09-22-2006, 06:09 AM
fat40's Avatar
Registered User
 
Last photo:
Join Date: Dec 2005
Location: indianapolis , In
Age: 76
Posts: 106
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
Oil Leak

Guys

Thanks for the replies, I removed the oil seal in the front cover, it had some material on the seal that was lose, I am in the process of installing a new seal, hope that will solve the leak.

THANKS AGAIN---------------FAT40
Reply With Quote Quick reply to this message

Recent Engine posts with photos

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
M.S. requested joke thread hotrodit Off-Topic 187 08-31-2014 06:14 AM
Oil Leak pjarrett Engine 11 07-03-2006 10:38 AM
Oil leak at MSD distributor base? TVR383 Engine 2 10-28-2005 03:37 PM
Oil leak fred56 Engine 2 12-13-2004 12:45 PM
Oil leak still?? leastbay Engine 8 08-15-2004 12:41 PM


All times are GMT -6. The time now is 07:32 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.