oil leaks from hp oil pump??...help please!! - Hot Rod Forum : Hotrodders Bulletin Board
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Engine
User Name
Password
lost password?   |   register now

Reply
 
LinkBack Thread Tools
  #1 (permalink)  
Old 06-04-2012, 01:03 PM
Registered User
 
Join Date: Apr 2012
Posts: 15
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
oil leaks from hp oil pump??...help please!!

I have a 406 sbc motor with large oil pan and 485hp and torque. I had a massive blow out through an o ring in a sandwich adapter from oil cooler. I replaced the adapter and o ring. Now i have little oil leaks a few weeks later all over the place. My oil pressure is @ 85lbs at start and 72 at warm idle. Also my fuel pump was getting wet and was under the impression it was a bad fuel pump as it is hp also....and seems high with 6.5 lbs of fuel pressure/// but it is oil on top not gas..now the sandwich adapter seems to have oil running down the oil filter...so before i replace every seal and gasket could it be this high oil pressure killing me with leaks ?? any help would be greatly appreciated!!
Attached Thumbnails
Click image for larger version

Name:	chevelle red valve.jpg
Views:	30
Size:	1.26 MB
ID:	65802  

    Advertisement
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2 (permalink)  
Old 06-04-2012, 02:00 PM
Richiehd's Avatar
JS-70
 
Last photo:
Join Date: Jun 2011
Location: Jupiter FL
Posts: 847
Wiki Edits: 0

Thanks: 158
Thanked 56 Times in 49 Posts
Wow, thats a lot of oil pressure at idle. However, do you have breathers and PCV on that motor? Both covers?
Reply With Quote Quick reply to this message
  #3 (permalink)  
Old 06-04-2012, 02:16 PM
Registered User
 
Last photo:
Join Date: May 2009
Location: S/E Michigan
Posts: 650
Wiki Edits: 0

Thanks: 0
Thanked 9 Times in 9 Posts
What type(weight) of oil?

That pressure is excessive, 80lbs cold will burst a filter or pop the filter gasket.

Whats the pressure at 3000rpm warm?
Reply With Quote Quick reply to this message
  #4 (permalink)  
Old 06-04-2012, 02:51 PM
S10 Racer's Avatar
http://www.warsprints.com
 

Last journal entry: W.A.R. (Wingless Auto Racing) Sprint Car Racing
Last photo:
Join Date: Nov 2007
Location: At The Dirt Tracks
Age: 55
Posts: 1,888
Wiki Edits: 0

Thanks: 3
Thanked 62 Times in 56 Posts
Yes, your oil pressure is wayyyy too high. You need to either change the pressure spring or go to a high volume pump. You could use a stock pump on that motor with no problems. The excessive pressure is your problem.
Reply With Quote Quick reply to this message
  #5 (permalink)  
Old 06-04-2012, 03:48 PM
Registered User
 
Join Date: Apr 2012
Posts: 15
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
I have a breather on one valve cover and was running 10w 30 mobil one and switched over to 10w 40mobile one ....So i need to replace the hp oil pump with hv oil pump ...ill check the 3000 rpm pressure tonight and respond. thanks for all the input.
Reply With Quote Quick reply to this message
  #6 (permalink)  
Old 06-04-2012, 03:55 PM
cool rockin daddy's Avatar
1.21 giga-watts???!!!!
 
Join Date: Aug 2003
Location: wherever cool cars are
Posts: 1,535
Wiki Edits: 0

Thanks: 0
Thanked 3 Times in 3 Posts
What is this engine used for? If street use, put a standard pressure, standard volume GM pump in it. Don't need anything else.
Reply With Quote Quick reply to this message
  #7 (permalink)  
Old 06-04-2012, 04:08 PM
Registered User
 
Join Date: Apr 2012
Posts: 15
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
I do daily driver it but occasional drag strip also.... it gets some what of a beating at the drag strip but it will be once every couple of months.
Reply With Quote Quick reply to this message
  #8 (permalink)  
Old 06-04-2012, 04:15 PM
Registered User
 
Last photo:
Join Date: Jul 2004
Location: At Speed
Age: 51
Posts: 1,345
Wiki Edits: 0

Thanks: 2
Thanked 29 Times in 29 Posts
I've built lots of racing engines that have 75psi pressure with 140 degree oil at startup. After a couple hours at WOT, they idle at 35psi. The filter should be able to withstand 150psi without leaking. The leak out the weep hole in the fuel pump can be fixed by plugging it. I use a rivet with RTV on it.
Reply With Quote Quick reply to this message
  #9 (permalink)  
Old 06-04-2012, 07:15 PM
Registered User
 
Join Date: Apr 2012
Posts: 15
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
so ....Ive looked around the site and this is what im finding ... My oil smells like gas and i have oil slung all over the place..and yes atop the fuel pump. So besides having to get a new oil pump it seems like my fuel pump has been compromised as well as slinging oil all over the engine through the weep holes. The car sat for a few years so i guess this is what happens with that oil pressure and old seals and such...and changing the oil AGAIN...man this sport is no joke when it comes to the pocket!! and after i do all this im sure the rings are next and the head gaskets too....no crying in motorsports huh?
Reply With Quote Quick reply to this message
  #10 (permalink)  
Old 06-05-2012, 05:32 PM
6426yy's Avatar
Member
 
Last photo:
Join Date: Nov 2003
Location: Macomb Il.
Age: 35
Posts: 551
Wiki Edits: 0

Thanks: 1
Thanked 1 Time in 1 Post
Your not running a PVC valve? I'd start there and drop to a lower viscosity oil before I pulled it apart.
Reply With Quote Quick reply to this message

Recent Engine posts with photos

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
i have a 70 buick 455 fresh bottom end and new high out put oil pump still no oil pre tpisuper10 Engine 12 09-22-2008 09:26 PM
oil leaks mrobby440 Engine 2 05-14-2007 02:24 PM
Please help to diagnose- engine with no oil pressure. Oil pump failed? killerformula Engine 4 12-26-2006 10:25 PM
oil leaks carnell Engine 10 12-14-2003 07:31 PM
HV oil pump makes oil filter seal leak WBrianS Engine 13 11-20-2003 01:56 AM


All times are GMT -6. The time now is 07:21 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.