oil out of dipstick? - Hot Rod Forum : Hotrodders Bulletin Board
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Engine
User Name
Password
lost password?   |   register now

Reply
 
LinkBack Thread Tools
  #1 (permalink)  
Old 11-07-2004, 03:05 PM
Novaman78's Avatar
Kill It & Grill It
 

Last journal entry: New door panels
Last photo:
Join Date: Oct 2003
Location: Bonne Terre Missouri
Age: 28
Posts: 219
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
oil out of dipstick?

why does oil keep coming up out of my dipstick tube? It is a sbc 305 with a melling high volume pump and the spring that came with the pump. I don't think it happens everytime i drive put i was just wondering if it is something to be worried about? The engine was rebuilt back in august so its not that old. Any help is appreciated.

    Advertisement
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2 (permalink)  
Old 11-07-2004, 03:10 PM
DoubleVision's Avatar
Not Considered a Senior Member
 
Last photo:
Join Date: Oct 2002
Location: Heart Of Dixie
Age: 40
Posts: 10,657
Wiki Edits: 0

Thanks: 15
Thanked 59 Times in 56 Posts
Is the PCV valve operational? is it over filled with oil due to a incorrect lenth dipstick?
Reply With Quote Quick reply to this message
  #3 (permalink)  
Old 11-07-2004, 04:53 PM
Member
 
Join Date: Apr 2004
Location: Cassville,MO
Posts: 817
Wiki Edits: 0

Thanks: 21
Thanked 44 Times in 40 Posts
If the PVC system is good you have excessive blow by getting past the rings.
Reply With Quote Quick reply to this message
  #4 (permalink)  
Old 11-07-2004, 06:09 PM
Novaman78's Avatar
Kill It & Grill It
 

Last journal entry: New door panels
Last photo:
Join Date: Oct 2003
Location: Bonne Terre Missouri
Age: 28
Posts: 219
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
my buddy helped me figure it out. I have a pcv valve but when i put the engine together i forgot a breather in the valve cover and there was just a plug there. The engine was building up pressure and coming out dipstick tube. Thanks for the help guys.
Reply With Quote Quick reply to this message

Recent Engine posts with photos

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -6. The time now is 03:46 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.