oil pump priming - Hot Rod Forum : Hotrodders Bulletin Board
Hotrodders.com -- Hot Rod Forum

Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Engine
User Name
lost password?   |   register now

LinkBack Thread Tools
  #1 (permalink)  
Old 05-02-2003, 06:59 PM
Registered User
Join Date: May 2003
Location: Albany, GA
Posts: 3
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
Question oil pump priming

thanks trees had step away for a moment back to the beging I am priming the oil pump on 327 the intake is not installed yet an I am using a oil pump priming tool when i start running the drill oil is only coming out of about two of the rockers all of the oil is coming out around the top of the priming tool i installed a high volume oil should the pump be pushing oil out this way or should it be push oil out of the 16 rockers

Reply With Quote Quick reply to this message
Sponsored Links
  #2 (permalink)  
Old 05-03-2003, 04:46 AM
woodz428's Avatar
Troll Hunter
Last photo:
Join Date: Sep 2002
Location: Philo,Il
Posts: 2,701
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts

It's possible that you have the lifters adjusted too tight, which could put the oil passages in the lifter so that oil won't flow through them.
Reply With Quote Quick reply to this message

Recent Engine posts with photos
Gear in this thread - Powered by O'Reilly Auto Parts

Quick Reply

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:
Please select your insurance company (Optional)


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -6. The time now is 09:25 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2015, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.