Olds 350 rocket lifter oiling problem?? - Hot Rod Forum : Hotrodders Bulletin Board
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Engine
User Name
Password
lost password?   |   register now

Reply
 
LinkBack Thread Tools
  #1 (permalink)  
Old 07-29-2006, 03:03 PM
speedracer0006's Avatar
Registered User
 

Last journal entry: more pics
Last photo:
Join Date: Oct 2003
Location: wisconsin
Age: 32
Posts: 8
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
Olds 350 rocket lifter oiling problem??

68-70 350 rocket new hi volume oil pump new lifters engine was machined at well known shop. shop put in cam bearings and owner built motor. bought motor from owner and prepped to put into a 79 buick regal. motor is running and is perfectly timed, carb is right ,but #7 lifters will not pump up also no oil is comming up to aftermarket oil pressure guage untill high rpm's. any thoughts???????

    Advertisement
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2 (permalink)  
Old 07-30-2006, 09:02 AM
Registered User
 
Join Date: Nov 2005
Location: Duffield ,Va
Age: 67
Posts: 526
Wiki Edits: 0

Thanks: 0
Thanked 1 Time in 1 Post
Quote:
Originally Posted by speedracer0006
68-70 350 rocket new hi volume oil pump new lifters engine was machined at well known shop. shop put in cam bearings and owner built motor. bought motor from owner and prepped to put into a 79 buick regal. motor is running and is perfectly timed, carb is right ,but #7 lifters will not pump up also no oil is comming up to aftermarket oil pressure guage untill high rpm's. any thoughts???????
My first thought would be that maybe there is an oil plug (used to route oil throught the passages)left out in the block somewhere, or relief valve on pump stuck open. Just a few thoughts.
Reply With Quote Quick reply to this message
  #3 (permalink)  
Old 07-30-2006, 09:24 PM
speedracer0006's Avatar
Registered User
 

Last journal entry: more pics
Last photo:
Join Date: Oct 2003
Location: wisconsin
Age: 32
Posts: 8
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
Quote:
Originally Posted by dgcantrellsr
My first thought would be that maybe there is an oil plug (used to route oil throught the passages)left out in the block somewhere, or relief valve on pump stuck open. Just a few thoughts.
After I posted thread upon teardown of engine while in car, I was looking down oil galley holes and noticed plug was missing. Do you or any one know what type of plug i need for left bank rear plug(Driver side), and where can i get one?????
Reply With Quote Quick reply to this message
  #4 (permalink)  
Old 07-31-2006, 07:55 AM
nitro_baller4692's Avatar
floppers forever
 
Join Date: Jun 2006
Location: illinois
Posts: 791
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
it's a national pipe thread you can get at the hardware store.
Reply With Quote Quick reply to this message

Recent Engine posts with photos

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Valve Lash adjustment hiball Engine 36 05-11-2009 10:12 AM
350 Olds 84montess Engine 8 08-04-2006 10:07 PM
olds 350 overhaul Blob Engine 3 11-19-2004 05:46 PM
Olds 350 rocket 5.0 freak Engine 1 08-08-2004 10:56 PM
350 Rocket Block CLJeepster Engine 1 05-03-2004 07:44 AM


All times are GMT -6. The time now is 06:21 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.