Hot Rod Forum : Hotrodders Bulletin Board - View Single Post - Olds 98 Ignition Module Problems
View Single Post
  #1 (permalink)  
Old 01-11-2004, 10:55 AM
awbazar awbazar is offline
Member
 
Join Date: Nov 2002
Location: Scottsville
Posts: 123
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
Olds 98 Ignition Module Problems

I have had repeated problems with Olds 98 ignition modules. Starting with a 1987 Olds 98, I encountered high temperature ignition cut out.

My 1990 Olds had the ignition module and 3 coil tower relocated from the fire wall side of the V-6 to the drivers side front of the V-6. The 1990 Olds 98 failed to start at temperatures below 30 degrees so I changed the ignition module with a junk yard unit from a Buick. That worked out fine till this year when we hit 10 degrees F and now I have to warm the ignition module up again with a trouble lamp under the heat sink to get the car to start.

I would like to know if other Olds 98 owners have had low temperature starting problems on 1990 Olds models which have the 3 spark coils mounted on top of the ignition module. At low temperatures, the car acts like it wants to start and run but never quite makes it until the ignition module is warmed up either in a heated garage or by placing a trouble light near the heat sink long enough to warm up the ignition module.

Since my 1990 Olds 98 is now 14 years old, the original ignition module may have become thermally sensitive moreso than when new. I did not bite the bullet for a brand new module but used a junk yard replacement which had some years under its belt too.
Reply With Quote