Overcharging - Hot Rod Forum : Hotrodders Bulletin Board
Hotrodders.com -- Hot Rod Forum

Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Electrical
User Name
lost password?   |   register now

LinkBack Thread Tools
  #1 (permalink)  
Old 01-28-2013, 10:32 PM
Registered User
Join Date: Jan 2013
Posts: 1
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts

I have a 31 ford (fiberglass body) that I just finished rewiring under the dash. I must of screwed something up. The car was running fine with all gauges working great. Now my in dash amp gauge is showing about 15.5 to 16 voits. It has the regulator on the fire wall. Did I wire something wrong??? Please help!!

Reply With Quote Quick reply to this message
Sponsored Links
  #2 (permalink)  
Old 01-29-2013, 04:48 PM
T-bucket23's Avatar
Hotrodders.com Moderator
Last wiki edit: Engine basic condition - how to check Last photo:
Join Date: Aug 2005
Location: Massachusetts
Age: 58
Posts: 5,936
Wiki Edits: 26

Thanks: 22
Thanked 272 Times in 227 Posts
Did you run a good ground to the regulator
Artificial Intelligence is no match for Natural Stupidity

Reply With Quote Quick reply to this message

Recent Electrical posts with photos
Gear in this thread - Powered by O'Reilly Auto Parts

Quick Reply

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:
Please select your insurance company (Optional)


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Similar Threads
Thread Thread Starter Forum Replies Last Post
Is my alternator overcharging? drchip Electrical 7 04-28-2011 09:15 AM
alternator is overcharging - need advice what to do pigjamelectric Electrical 4 12-02-2010 03:51 PM
Powermaster 140A Overcharging 68NovaSS Electrical 8 10-08-2007 10:53 PM
Am I overcharging?? cutsupreme Electrical 4 06-16-2007 06:38 AM
altinator overcharging walkn slow Electrical 2 03-20-2007 11:09 AM

All times are GMT -6. The time now is 04:45 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2015, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.