Paint problem - Hot Rod Forum : Hotrodders Bulletin Board -- Hot Rod Forum

Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Body - Exterior
User Name
lost password?   |   register now

LinkBack Thread Tools
  #1 (permalink)  
Old 11-15-2004, 02:27 PM
Registered User
Join Date: Nov 2004
Location: NC
Age: 41
Posts: 2
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
Unhappy Paint problem

I have been in the procces of painting my Car hauler. Problem is I primed it with Napa Econo-Body Acrylic primer surfacer mixed 50 50 with laquer thinner. Waited a week and wet sanded it and then painted it with rustoleum gloss black. It looked at first likeat the paint was seperating from the primer in spots, but after lightly sanding a affected area it looks like the primer was absorbing the paint like a sponge and it may need to just be re coated. Any ideas ??? Does surfacer tend to act this way? seeing its a trailer i did not put a whole lot of attention to detail into wet sanding the primer and it may still have beed thick in areas.

What should i do know???????????

Any help would be greatly appreciated....

Reply With Quote Quick reply to this message
Sponsored Links
  #2 (permalink)  
Old 11-15-2004, 02:51 PM
BarryK's Avatar
Last photo:
Join Date: Apr 2004
Posts: 3,596
Wiki Edits: 0

Thanks: 11
Thanked 82 Times in 51 Posts
Just the restoleum attacking the primer, after the paint dries
the paint will act as a sealer and you can sand paint (without breaking through) and re-coat and this will not happen again.

Also adding to this problem could have been water in airline or water in cheap grade of lacquer thinner.
Also, some lacquer thinners are made only to clean paint guns and not to be mixed with paint.
Wet sanding may also not have helped out.
Reply With Quote Quick reply to this message
  #3 (permalink)  
Old 11-15-2004, 06:46 PM
Registered User
Join Date: Nov 2004
Location: NC
Age: 41
Posts: 2
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts

Hey thanks a lot, I was hoping it would be something simple like that and not have to strip it all again.

Thanx again

Reply With Quote Quick reply to this message

Recent Body - Exterior posts with photos
Gear in this thread - Powered by O'Reilly Auto Parts

Quick Reply

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:
Please select your insurance company (Optional)


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -6. The time now is 03:31 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2015, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright 1999 - 2012. All Rights Reserved.