PCV valve, smoke out exhaust - Hot Rod Forum : Hotrodders Bulletin Board
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Engine
User Name
Password
lost password?   |   register now

Reply
 
LinkBack Thread Tools
  #1 (permalink)  
Old 07-11-2009, 11:11 PM
Registered User
 
Last photo:
Join Date: Apr 2009
Location: denver
Posts: 189
Wiki Edits: 0

Thanks: 0
Thanked 1 Time in 1 Post
PCV valve, smoke out exhaust

So I've had the 355 for a while, got most of the details figured out; but i have a problem.

when i rev the engine above 3000 rpm or so, i get smoke from burned oil. I have had someone confirm it as well. Just had the heads redone, intake manifold is on right.

I have an edelbrock 600 cfm carb with the pcv valve on the drivers side, and a breather on the other. I just now realized that it doesn't make sense. Should i only have a pvc valve so that air doesn't get sucked through the breather, through the engine, and into the carb???

Its i really build 355, 7000rpm redline says the cam, mechanical lifters, 11.5:1 CR, dual exahust.

I only get the oil smoke at high rpm's, and the spark plugs verify it. Is there a change it would be the piston rings??? i go through a quart of oil every 200 miles or so, and the inside of the intake manifold is dark colored. And its a manual tranny, so no vacuum lines there. The only vacuum lines i have used a power brakes and pcv valve. All the intake manifold ports are plugged, and the unused carb ports are capped.

Ideas?? Should i just cap one of the valve cover holes???

Thanks, Josh

    Advertisement
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2 (permalink)  
Old 07-11-2009, 11:15 PM
Registered User
 
Last photo:
Join Date: Apr 2009
Location: denver
Posts: 189
Wiki Edits: 0

Thanks: 0
Thanked 1 Time in 1 Post
Oil for sbc 355

On a similar note, i am running 40-50psi oil pressure at idle, and 70-80 at 4000rpm. Using mobil 1 15w-50 racing oil. Too much pressure? Is it causing to much splatter in the valve covers??

Has anyone herd of using high zinc content diesel oil like 10w-40 for built SBC's???
Reply With Quote Quick reply to this message
  #3 (permalink)  
Old 07-12-2009, 03:23 AM
DoubleVision's Avatar
Not Considered a Senior Member
 
Last photo:
Join Date: Oct 2002
Location: Heart Of Dixie
Age: 40
Posts: 10,658
Wiki Edits: 0

Thanks: 15
Thanked 60 Times in 57 Posts
If you plugged one valve cover the pcv system couldn`t work as it has to breathe and thats why there`s a breather in the other valve cover, this is where it gets it`s air.
Is there any oil in the intake? if so you have a intake leak.
If not then I would say it`s either valve guides or valve seals. Possibly rings.
Reply With Quote Quick reply to this message
  #4 (permalink)  
Old 07-12-2009, 08:40 AM
XNTRCI-T's Avatar
AKA Lee in KC
 
Last photo:
Join Date: Apr 2006
Location: Overland Park, KS
Age: 66
Posts: 530
Wiki Edits: 0

Thanks: 0
Thanked 1 Time in 1 Post
Is there a baffle in the valve cover under the PCV valve? If not, you may be sucking a lot of oil through the PCV. Also, check to see that the PCV valve is actually there and functioning. It should rattle when you shake it. I once bought a billet PCV "valve" and discovered there was no actual valve in it. Just a straight pass-through.
Reply With Quote Quick reply to this message
  #5 (permalink)  
Old 07-12-2009, 06:30 PM
Registered User
 
Last photo:
Join Date: Apr 2009
Location: denver
Posts: 189
Wiki Edits: 0

Thanks: 0
Thanked 1 Time in 1 Post
The valve itself is fine. there is a baffle, but oil can still get through. Do they make something that is an actual filter, not just small holes??

If something was wrong with the rings, would i see other problems?? I only get smoke above 3000 or so, and i have good compression.
Reply With Quote Quick reply to this message

Recent Engine posts with photos

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Correct way to set valves on sbc w/ solid flat tappit camshaft? Joshua Lee Engine 17 02-09-2011 06:55 PM
Valve Lash adjustment hiball Engine 36 05-11-2009 11:12 AM
Why Is Smoke Coming Out My Exhaust? CCR Engine 10 11-05-2004 10:29 AM
PCV Valve black66 Engine 4 08-23-2004 08:26 PM
valvetrain gurus: need help identifying mysterious valve noise blndweasel Engine 10 03-04-2003 08:59 PM


All times are GMT -6. The time now is 05:25 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.