Hot Rod Forum : Hotrodders Bulletin Board - View Single Post - Pinging on cruise part throttle acceleration?
View Single Post
  #35 (permalink)  
Old 07-13-2010, 11:32 AM
kyle86 kyle86 is offline
Registered User
 
Last photo:
Join Date: Jan 2010
Location: ga
Posts: 132
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
Quote:
Originally Posted by Custom10
Just as a note on this to point something out, if the current setup is working for you then so be it but...

Your limiter plate is on the opposite side of the can push rod than the crane part, the crane limiter sits under the other screw and limits the amount that the rod can travel back thus shortening the total travel which equates to less advance added when in operation (this effects your base timing so you need to reset it after installing the crane part) With what you have you are in effect limiting the travel of the can push rod however the can will start to add vac advance at the same time as it did before. Since you do not have an adjustable vac can set screw it would be advantageous to put the limiter on the back side as the crane one does, this will raise the effective start point of the vacuum advance coming in because the spring is preloaded by the limiter plate and therefor it will drop out sooner as well so when the engine vacuum drops on light trottle the vac advance will disappear sooner which may help a pinging issue.
That is a good idea, I didn't think about that. I might just have to buy an adjustable vac can then. I don't think this one works very well with my combo.

Or maybe I'll try welding a hook type deal on my little limiter plate that will limit it from the back side. I don't know if it's more trouble then it's worth though to mess with it. OR maybe I can fab something else up to work kind of like the crane limiter.

Last edited by kyle86; 07-13-2010 at 11:42 AM.
Reply With Quote