Hot Rod Forum : Hotrodders Bulletin Board - View Single Post - Piston ring damage
View Single Post
  #5 (permalink)  
Old 12-16-2012, 06:21 PM
coldfreshwater coldfreshwater is offline
Registered User
 
Join Date: Dec 2012
Posts: 6
Wiki Edits: 0

Thanks: 1
Thanked 0 Times in 0 Posts
No, it did not get hot.The oil pan was about to start dripping & I don"t want any oil on my drive-way because I paid 9,000 dollars for the drive-way cement & the water pump was leaking ,also, so that is why that was re-placed.Then when I went to pick up the water pump I mentioned to the salesperson that it had stalled a few times & she suggested it might be the fuel pump ,so I bought one& took it with me back to the repair shop & they probably just put it in because I had it but,maybe, I didn"t need it. Anyway, my car does not stall anymore & everything is fixed except when I first start it up the tensioner belt makes a slight "chirping" sound.I was told they should have re-placed the water pump belt when the water pump was re-placed but that was not done. I know I need a new car because I was told that last year because the bottom is rusting out but a little caulk keeps the wetness out(my idea) & it really works,however, this one rides better than the new ones I drove. I drove a new Focus,Fusion,& Hyundi & when I got back in my Topaz it was a relief(like being back in the saddle again.)The Hyundi salesman even drove my Topaz because I asked him if he could figure out why I liked it better ,& all he said was that it needed new struts which it doesn"t. I know it won"t last forever but I was just wondering how long it might last.I am really worried because I had to add half a quart of oil after driving only about 300 miles.The motor sounds ok & it doesn"t sound old or unusual.
Reply With Quote