Hot Rod Forum : Hotrodders Bulletin Board - View Single Post - pontiac 350 idles at 1000 rpm in park 600rpm in drive
View Single Post
  #1 (permalink)  
Old 07-18-2012, 09:57 PM
starin starin is offline
Registered User
 
Join Date: Jul 2012
Posts: 63
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
pontiac 350 idles at 1000 rpm in park 600rpm in drive

Hey guys so thanks everyone helping me with my firing order issue / timing gear issue.

now my next problem is that when i have the car in park it idles at 1000 rpm but when i put it in drive it idles at 600 rpm. i sprayed some carb cleaner around the intake and carb base and no change in rpm. I'm pretty sure i have no leaks. the motor is a pontiac 350 out of a 1972 lemans. it has the original points distributor but i put a petronix in it. however im new to the whole world of wrenching and did not change the springs or the plate or the vaccuum canister and these were all original.

when i timed the car i disconnected the vac advance and plugged it as well as plugged the manifold source. i timed it at 12 degrees. when i hooked the vacumm advance line back to the manifold vac i was under the understanding the timing was supposed to go up a little. when i put the timing light to it. at idle it was still at 12 degrees.

do you guys think the distributor is the problem? i bought an A1 CARDONE reman distributor today and am going to swap my pertronix into that. but if its not the problem id rather save the money.

what do you guys think?

Thanks in advance.
Reply With Quote