popping at high rpm's - Hot Rod Forum : Hotrodders Bulletin Board
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Engine
User Name
Password
lost password?   |   register now

Reply
 
LinkBack Thread Tools
  #1 (permalink)  
Old 07-23-2006, 04:24 PM
dadstoy70's Avatar
dadstoy70
 
Join Date: Jul 2006
Location: ohio
Age: 47
Posts: 13
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
popping at high rpm's

hi guys,
i'm driving myself crazy trying to figure out why i'm getting a "popping" sound out of the carburetor at high rpm's. i've tried adjusting the carb and timing to a few different settings and it's still there. i've got a sb 400 chevy ( .030 over), edelbrock performer intake, mild cam and a q-jet 750 cfm carb right now. is my carb taking a crap on me??? HELP!!
any help would be appreciated, dave

    Advertisement

Last edited by dadstoy70; 07-23-2006 at 04:49 PM. Reason: no response
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2 (permalink)  
Old 07-23-2006, 04:55 PM
Steve karch's Avatar
Member
 
Last photo:
Join Date: Feb 2002
Location: Regina, Saskatchewan
Age: 55
Posts: 414
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
What RPM is this happening. What kind of heads and are the valve springs matched to the cam. It might be the carb but weak valve springs may also cause this.
Reply With Quote Quick reply to this message
  #3 (permalink)  
Old 07-23-2006, 04:59 PM
xntrik's Avatar
Save a horse, Ride a Cowboy.
 
Last photo:
Join Date: Jul 2005
Location: Arkansas
Posts: 5,131
Wiki Edits: 0

Thanks: 0
Thanked 1 Time in 1 Post
Quote:
Originally Posted by dadstoy70
hi guys,
i'm driving myself crazy trying to figure out why i'm getting a "popping" sound out of the carburetor at high rpm's. i've tried adjusting the carb and timing to a few different settings and it's still there. i've got a sb 400 chevy ( .030 over), edelbrock performer intake, mild cam and a q-jet 750 cfm carb right now. is my carb taking a crap on me??? HELP!!
any help would be appreciated, dave

How did you adjust the carb? Using the idle mixture screws?

How do you know it is carb and not ignition? Fuel delivery?

www.readershotrods.com
Reply With Quote Quick reply to this message
  #4 (permalink)  
Old 07-23-2006, 05:03 PM
dadstoy70's Avatar
dadstoy70
 
Join Date: Jul 2006
Location: ohio
Age: 47
Posts: 13
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
popping

it happens above the 4,000 rpm range. i notice it most when i put my foot in it. i'm running stock heads and a mild cam ( just above a "tow package" cam )
it just started this recently and the only thing i've changed is the spark plugs. i went to shorty plugs because of my headers. i don't know weather to pursue a carb issue or ignition problem.
Reply With Quote Quick reply to this message
  #5 (permalink)  
Old 07-23-2006, 05:05 PM
poncho62's Avatar
Out of the Loop Moderator
 
Last wiki edit: Streetbeasts links
Last journal entry: at car show
Last photo:
Join Date: Oct 2003
Location: Hanover, Ontario, Canada
Age: 62
Posts: 16,898
Wiki Edits: 5

Thanks: 20
Thanked 260 Times in 213 Posts
1/ Running out of gas...........

2/ Valve setting too tight

3/ Cracked/broken rocker arm(s).........bent pushrod
__________________
Ontario Rodders

Budget RVs
Reply With Quote Quick reply to this message
  #6 (permalink)  
Old 07-23-2006, 05:06 PM
dadstoy70's Avatar
dadstoy70
 
Join Date: Jul 2006
Location: ohio
Age: 47
Posts: 13
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
popping

yes, i used the mixture screws to try and get rid of the popping.
Reply With Quote Quick reply to this message
  #7 (permalink)  
Old 07-23-2006, 05:10 PM
dadstoy70's Avatar
dadstoy70
 
Join Date: Jul 2006
Location: ohio
Age: 47
Posts: 13
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
popping

thanks for all the advice guys. i guess i'll start with process of elimination. the cheapest first of course!
Reply With Quote Quick reply to this message
  #8 (permalink)  
Old 07-23-2006, 06:01 PM
Member
 

Last journal entry: frame build
Last photo:
Join Date: Apr 2005
Location: sioux falls, sd
Age: 68
Posts: 601
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
Sounds to me like your getting a little valve float. read that weak valve springs or possibly a lifter pumping up.
Reply With Quote Quick reply to this message
  #9 (permalink)  
Old 07-23-2006, 06:02 PM
Member
 
Join Date: Aug 2003
Location: California
Posts: 903
Wiki Edits: 0

Thanks: 0
Thanked 1 Time in 1 Post
dadstoy70,

This could be a flat cam also. When the exhaust valve does not open enough to let the burnt gasses out of the cylinder then you will hear a popping coming from the carb. To see if this is the problem take a valve cover off and hook up your timing light to any spark plug. Then start the engine and let it idle. Using the timing light to stop the action of the moving rockers you will see just how much movement each rocker has. With a flat cam lobe the rocker will just sort of wiggle. They do not make any noise because they never open enough to make any noise. And the engine runs ok at lower RPM's because some of the gasses can get out but at higher RPM's these gasses get backed up into the intake and you hear the popping.

Good Luck and Good Hunting
Scholman
Reply With Quote Quick reply to this message
  #10 (permalink)  
Old 07-23-2006, 07:39 PM
E.T. divided by $ spent= Speed
 
Last photo:
Join Date: May 2002
Location: NYS america's unwiped butt
Age: 35
Posts: 1,858
Wiki Edits: 0

Thanks: 0
Thanked 5 Times in 5 Posts
Quote:
Originally Posted by dadstoy70
it just started this recently and the only thing i've changed is the spark plugs. i went to shorty plugs because of my headers.
Thats were I would start myself.Are you plugs white after a WOT blast?? If you changed the heat range on the plugs you might need to richen up the carb a bit,with jets and metering rods.
Also if you just added headers from manifolds you might need to ricken up your jets a couple sizes.
Reply With Quote Quick reply to this message

Recent Engine posts with photos

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Port or Full time vacuum cool rockin daddy Engine 129 10-05-2010 03:00 PM
too high rpm help jcdaly Transmission - Rearend 25 01-31-2005 08:03 PM
Dyno Pulls and Blow by at high RPM NoEgoMan100 Engine 5 12-07-2004 11:57 AM
Emissions HELP cutsupreme Engine 33 12-27-2003 08:22 AM
high rpm 55relic General Rodding Tech 1 10-09-2003 01:22 AM


All times are GMT -6. The time now is 10:35 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.