POR15 Application Questions w/Pics - Page 2 - Hot Rod Forum : Hotrodders Bulletin Board
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Body - Exterior
User Name
Password
lost password?   |   register now

Reply
 
LinkBack Thread Tools
  #16 (permalink)  
Old 02-08-2013, 02:42 PM
mitmaks's Avatar
Member
 

Last journal entry: Grille
Last photo:
Join Date: Sep 2002
Location: Washington
Age: 31
Posts: 1,599
Wiki Edits: 0

Thanks: 4
Thanked 10 Times in 10 Posts
Quote:
Originally Posted by Riot Racing View Post
I considered that but kind of doubt this is what caused it. The first pieces I POR15 had this same issue and I only applied 1 coat of POR15 to that surface and the bumps were even worse than these pieces.



I used a wet rag to clean the sandblasted metal. I then used a Tack cloth once the metal was dry to make sure there was no contamination on the metal. I am skeptical that these bumps are lint.
I looked at close up pictures and I can clearly see contamination on metal before POR15 was applied. You should've used some scuff pad/sand paper to knock down whatever is on there (looks like some rough spots in the pictures) and then blow off and tack it real well.
If you had clean blasted metal you should've just used coat of epoxy primer and then a couple coats of high build urethane primer and sand that and it would've been ready for paint.

    Advertisement
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #17 (permalink)  
Old 02-08-2013, 02:51 PM
mitmaks's Avatar
Member
 

Last journal entry: Grille
Last photo:
Join Date: Sep 2002
Location: Washington
Age: 31
Posts: 1,599
Wiki Edits: 0

Thanks: 4
Thanked 10 Times in 10 Posts
Quote:
Originally Posted by Riot Racing View Post
POR15 instructions state to rinse the parts with water after each step of the process i listed
http://www.por15.com/Data%20Sheets/P...cationInfo.pdf

APPLICATION PROCEDURES
Surface preparation: Rusted surfaces are best; seasoned metal and
sandblasted surfaces are also good. Surface must be dry and free of
grease, oil, or other foreign substances.
TO COAT SMOOTH METAL SURFACES: First use Marine Clean to
clean and degrease the surface, when clean rinse with water and allow
area to dry. Second spray Metal Ready on surface full strength, keep wet
for 15-20 minutes then rinse with water and allow to completely dry. Use
of “rust converter” products is not recommended as they may affect
bonding of POR-15 to metal. POR-15 likes to adhere to surfaces with
“tooth” rather than smooth, glossy surfaces.
STIR CONTENTS THOROUGHLY before painting. Do not shake.
Refrigerate unused portion of POR-15 for longer shelf life.

It states to rinse off with water after you apply marine clean or metal ready, did you use any of those products? Simply rinsing blasted metal with water will just flash rust it and will cause problems down the road.
Reply With Quote Quick reply to this message
  #18 (permalink)  
Old 02-09-2013, 11:11 AM
Riot Racing's Avatar
Member
 

Last journal entry: Por 15
Last photo:
Join Date: Apr 2005
Location: Los Angeles
Posts: 399
Wiki Edits: 0

Thanks: 1
Thanked 1 Time in 1 Post
I'm starting to think that people are not reading my post in close detail...

So as a report back: I chipped a few of those pimple looks spots ont he surface and I do not see any rust or other contamination under the pimple. This makes me think the problem might be air. I want to talk to the POR15 company and see what they think. Again, im not really worried since it wont show but Id like to learn how to use this product better.
Reply With Quote Quick reply to this message

Recent Body - Exterior posts with photos

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Eaton Posi questions on application kieferrestoration Transmission - Rearend 1 03-29-2010 10:04 PM
4L60E - 2 Questions With Pics Micaletti Transmission - Rearend 2 04-21-2009 09:39 PM
Lizard skin application questions Michael Clark Body - Exterior 2 03-12-2008 06:06 AM
the plymouth.... A FEW QUESTIONS AND PICS h0trod389 Hotrodding Basics 11 05-03-2007 01:32 AM
questions on uploading pics chevyluvnpuppy Hotrodders' Lounge 5 09-06-2006 11:06 PM


All times are GMT -6. The time now is 10:07 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.