Hot Rod Forum : Hotrodders Bulletin Board

Hot Rod Forum : Hotrodders Bulletin Board (http://www.hotrodders.com/forum/)
-   Suspension - Brakes - Steering (http://www.hotrodders.com/forum/suspension-brakes-steering/)
-   -   Power brakes dont feel right...any suggestions? (http://www.hotrodders.com/forum/power-brakes-dont-feel-right-any-suggestions-225925.html)

chevyrestore 11-09-2012 10:59 PM

Power brakes dont feel right...any suggestions?
 
Hey guys. Got a 59 chevy truck with the classic performance power brake conversion on the frame (not up on the firewall).

My situation is the brakes work great but they always feel too hard, best way to describe it is when I hit the brake pedal the truck slows down but much slower than it should and the pedal is rock hard.

If I do a panic stop I can NEVER lock up the wheels, sometimes under a panic stop the pedal goes down just more than 1/2 way and is rock hard but the truck keeps going.

Is this a problem with the type of pad or a lack of vacuum or pushrod adjustment or what?

15-18" vacuum at idle, autozone semi-metallic pads, new brake fluid. Running the classic performance proportioning valve as well.

Thanks for any advise.

cobalt327 11-10-2012 05:34 AM

Quote:

Originally Posted by chevyrestore (Post 1609402)
Hey guys. Got a 59 chevy truck with the classic performance power brake conversion on the frame (not up on the firewall).

My situation is the brakes work great but they always feel too hard, best way to describe it is when I hit the brake pedal the truck slows down but much slower than it should and the pedal is rock hard.

If I do a panic stop I can NEVER lock up the wheels, sometimes under a panic stop the pedal goes down just more than 1/2 way and is rock hard but the truck keeps going.

Is this a problem with the type of pad or a lack of vacuum or pushrod adjustment or what?

15-18" vacuum at idle, autozone semi-metallic pads, new brake fluid. Running the classic performance proportioning valve as well.

Thanks for any advise.

It could be several things. Now, I'm going to assume the caliper/slave cylinder bores match up correctly to the master cylinder bore since you bought this from a reputable vendor. But if all else fails, look back at this.

The pedal ratio is one thing that can effect pedal effort. But usually when going from a manual to a power booster, the pedal ratio will be such that the brakes are too touchy, not too hard. But it's still something to consider, especially if the pedal assembly is different from stock or has been modified.

The most likely cause is a too small booster or not enough vacuum. You said you have 15 to 18 in/Hg vacuum. Depending on the booster size and type (dual or single diaphragm) and the actual vacuum, the range you give goes from borderline not enough (15") to enough (18"). This also depends on what you are using: disc/drum, disc/disc, or drum/drum. If you can give more info on your set up and the diameter of the booster and whether it's a dual diaphragm or not, this could help diagnose it.

NEW INTERIORS 11-10-2012 06:55 AM

I would also jack it up and make sure all four wheels is working..

knight hawk 11-10-2012 07:04 PM

try it with and without the vacumn connected

chevyrestore 11-15-2012 12:21 AM

I have tried it with and without vacuum, booster is definitely working. Its a disc disc setup, not sure on the booster. TCI made a power conversion kit with the brackets and new pedal assembly along with the CPP booster and master cylinder mounted on the frame.

How would I tell which booster it is? I think its the CPP 8" booster. Knowing this info where should I go from here?

I can definitely tell that the booster is helping stop the truck but its just too stiff of a pedal and I can NEVER lock up the wheels if it came down to needing to. I pinched the vacuum hose and got 2 stops until the vacuum was gone in the booster and then no more power assist.

cobalt327 11-15-2012 09:32 AM

Quote:

Originally Posted by chevyrestore (Post 1611403)
I have tried it with and without vacuum, booster is definitely working. Its a disc disc setup, not sure on the booster. TCI made a power conversion kit with the brackets and new pedal assembly along with the CPP booster and master cylinder mounted on the frame.

How would I tell which booster it is? I think its the CPP 8" booster. Knowing this info where should I go from here?

I can definitely tell that the booster is helping stop the truck but its just too stiff of a pedal and I can NEVER lock up the wheels if it came down to needing to. I pinched the vacuum hose and got 2 stops until the vacuum was gone in the booster and then no more power assist.

Measure the pedal ratio. A diagram showing how to determine the ratio is here.

chevyrestore 11-15-2012 09:46 AM

I wouldnt be able to meaure that because the pedal goes through the floor and is non removable since the pedal head is welded to the pedal arm that goes through the firewall and under the floor to the master cylinder setup. There is an adjustment screw im sure you guys know about to adjust the pedal height, can this being out of adjustment cause my concern?

Any way I can measure what youre talking about with the pedal ratio with it being set up the way I described?

1971BB427 11-15-2012 04:34 PM

You might have to guesstimate the ratio by estimating the pivot point to the pedal in a straight line, without regard to the shape of the arm through the floor. Then meausre from pivot point to the adjusting rod.
Another common cause of a hard pedal is too much preload on the master cylinder. Be sure you have a small amount of freeplay in the pedal before it starts to compress the piston in the master, or the brakes will be partially preloaded and make the pedal firmer. You can check this by grabbing the pedal with your hand and pushing/pulling and watching the adjusting rod to see if it has any clearance. Or disconnect the rod and see if it has play in it.

chevyrestore 11-27-2012 11:05 PM

I checked vacuum again, 19", adjusted the rod up and down a bunch and same feel only with the pedal in a different spot (higher or lower). Rebled all the brakes and same feel as well.

Tested the valve on the booster and thats working properly also and no vacuum leaks on booster hose coming from the engine.

I jacked up the truck in the rear and put it in drive, with the pedal pressed for a normal stop the wheels just slowed (did not stop), pressed harder, same thing, the wheels didnt completely stop until I really pressed very very hard and even then I think if someone had a breaker bar on the lug nuts they could still turn the wheel.

Im going to rip off the booster and drive it down to classic performance and have them swap it for another one to see if that fixes it. Ill let you guys know how it goes unless you have another thing to try first. Thanks again!

cobalt327 11-27-2012 11:58 PM

Are the rear brakes adjusted?

You said you have the CP prop valve. Is it adjustable? If you added it to the MC that already has it's own prop valve, you may have reduced the pressure to the rears too much unless the MC prop valve was disabled.

No way to change the pedal ratio easily, huh? That's a bummer- that might be all it needs if the rear brake adjustment and prop valve deal doesn't pan out.

gearheadslife 11-28-2012 12:08 AM

crack the line for the rears, and see if the pedal now is easier.. I'm guessing here that the rear brakes are in the master port nearest the booster, if the rubber line is failing internally, it block flow under pressure and make it hard to move the piston in the master.. as will a stuck propotioning valve that closed off the rears..

chevyrestore 11-28-2012 01:14 AM

The master cylinder is designed by CP also and they said for this setup to work properly I need the disc/disc prop valve and verified they gave me the correct one, only rubber lines are the 12" or so ones at the front calipers, all other lines are hard steel lines.

The rear end is from a 91-92 camaro with discs, how would an adjustment be done on this if any?


PROP valve is NON-adjustable designed for a disc/disc setup as is the master cylinder. When bleeding I get a good squirt from the rear bleeders so I think the valve is working properly and getting sufficient fluid to the rears.

gearheadslife 11-28-2012 12:07 PM

Quote:

Originally Posted by chevyrestore (Post 1616593)
The master cylinder is designed by CP also and they said for this setup to work properly I need the disc/disc prop valve and verified they gave me the correct one, only rubber lines are the 12" or so ones at the front calipers, all other lines are hard steel lines.

The rear end is from a 91-92 camaro with discs, how would an adjustment be done on this if any?


PROP valve is NON-adjustable designed for a disc/disc setup as is the master cylinder. When bleeding I get a good squirt from the rear bleeders so I think the valve is working properly and getting sufficient fluid to the rears.

sorry, buddy you HAVE a rubber line at the rear brakes.. the rearend moves, steel line would not work frame to rear..

chevyrestore 11-28-2012 11:25 PM

sorry my mistake there are short sections of rubber lines on the rear, when bleeding it did have good flow out of the bleed valve so I know the lines arent fully clogged under slight pressure, how would I test for internal failure in the rubber lines?

Should I still be looking at swapping out the booster or what?

chevyrestore 01-17-2013 12:30 PM

Hey its been raining here so I havent had any days to check the truck again, I replaced the rear rotors and pads and verified the pistons are free moving and not frozen anywhere, brakes still hard.
Any other ideas? I have no chance of locking up the wheels if I need to so I dont feel safe driving it.


All times are GMT -6. The time now is 03:32 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.