Power steering pump Failure? - Hot Rod Forum : Hotrodders Bulletin Board
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Suspension - Brakes - Steering
User Name
Password
lost password?   |   register now

Reply
 
LinkBack Thread Tools
  #1 (permalink)  
Old 05-26-2009, 08:15 AM
Registered User
 
Join Date: Jun 2007
Location: Middletown Ohio
Age: 40
Posts: 75
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
Power steering pump Failure?

I was running my car pretty hard the other night (74' Monte Carlo, Turbocharged) I wasn't turning a huge amount of RPM's or anything and when I got home, I stopped in the alley opened my garage and drove it in. The second I shut the car off I hear this sound like somebody's peeing on the floor.

I popped the hood and the inside of the power steering pulley is wet and there is fluid running out onto the garage floor. I walked outside and just where it sat running for a minute or so while I opened the garage was dry! The steering never acted funny or made any noise either. Just emptied itself of fluid the minute I shut off the engine. What gives?

Has anyone else just had a major dump of fluid out of the pump like this? could it be much more than just a blown seal? I am going to purchase a rebuild kit and tackle it myself. But I have never seen a leak like this before ever from a GM steering pump.

    Advertisement
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2 (permalink)  
Old 05-26-2009, 08:46 AM
83SILVRADO's Avatar
GROUND POUNDER
 
Last photo:
Join Date: Feb 2009
Location: South Carolina
Age: 23
Posts: 177
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
i dont think it could be much more than a blown seal. that sounds about right to me. but i am no expert. i would go ahead with what you said with the repair kit. good luck.
Reply With Quote Quick reply to this message
  #3 (permalink)  
Old 05-29-2009, 06:42 AM
Registered User
 
Join Date: Jun 2007
Location: Middletown Ohio
Age: 40
Posts: 75
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
Yup, A little more than a blown seal....



I pulled the pump and the pulley and noticed the shaft had about .015"-.030" axial play in the shaft. Killed the seal. I took the pump apart and went to the auto parts store. They didnt sell a rebuilt kit at my local NAPA or they were too lazy to look it up.

The store offered the pump or the pump with resivoir. I bought the pump only and with core returned it was $37.00

I put it together last night and one of the mounting points was not the same as the original and I had to make a spacer to get the belts to line up correctly.

Never is anything a direct bolt on anymore it seems.

The bushing or bearing was toast, bad. If I would have just put a new seal in it would have gone bad very quickly.
Reply With Quote Quick reply to this message

Recent Suspension - Brakes - Steering posts with photos

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
lwp swp power steering pump bracketry dirtinla Suspension - Brakes - Steering 6 01-01-2009 10:02 AM
power steering pump help, please steve t Suspension - Brakes - Steering 3 08-15-2008 05:50 PM
Power steering pump on blown motor Marcus Engine 14 05-16-2008 01:10 AM
power steering from long water pump to short water pump kellyem Suspension - Brakes - Steering 7 02-22-2004 07:22 PM
power steering pump impala dreaming Suspension - Brakes - Steering 3 02-15-2003 05:00 PM


All times are GMT -6. The time now is 06:18 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.