powerglide - Hot Rod Forum : Hotrodders Bulletin Board
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Transmission - Rearend
User Name
Password
lost password?   |   register now

Reply
 
LinkBack Thread Tools
  #1 (permalink)  
Old 12-11-2004, 09:39 PM
camnova's Avatar
New Member
 
Join Date: Feb 2004
Location: canada
Posts: 10
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
powerglide

i have a 1973 nova with a powerglide it wont go in reverse.
all the other gears work. it has the right amount of fluid. and there is no metal in the oil so what could be wrong bend linkige.
or do i need a new tranny.

    Advertisement
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2 (permalink)  
Old 12-12-2004, 07:39 AM
stu stu is offline
Member
 
Last photo:
Join Date: Aug 2004
Location: Saskatchewan
Age: 73
Posts: 428
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
There is only one unit applied for reverse in a Power Glide transmission.
The rear clutch.
Drop the pan and check for foreign material.
Given it's a 73 the seals are probably shrunk or ruptured.
Reply With Quote Quick reply to this message
  #3 (permalink)  
Old 12-12-2004, 08:43 AM
Crosley's Avatar
Hotrodders.com Moderator
 
Last wiki edit: T-350 rebuild tech
Last journal entry: Bar under the dash
Last photo:
Join Date: Nov 2002
Location: ... USA
Posts: 8,058
Wiki Edits: 1659

Thanks: 315
Thanked 94 Times in 91 Posts
Cool

If the shift linkage was bent or loose I would think the forward gears would not function correctly. Park may not function correctly too.


sounds like a reverse clutch problem as stu says
__________________
Some people are like Slinkies... Not really good for anything, but they still bring a smile to your face when you push them down a flight of stairs.
Reply With Quote Quick reply to this message

Recent Transmission - Rearend posts with photos

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -6. The time now is 11:53 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.