Powerglide Transmission - Hot Rod Forum : Hotrodders Bulletin Board
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Transmission - Rearend
User Name
Password
lost password?   |   register now

Reply
 
LinkBack Thread Tools
  #1 (permalink)  
Old 09-24-2002, 01:21 PM
Registered User
 
Join Date: Sep 2002
Location: Riverdale, Georgia
Posts: 3
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
Post Powerglide Transmission

I have a 69 Camaro with a Powerglide ttransmission that suddenly without warning just quit while I was driving. The car will not move in any forward gear or reverse. When I got the car home I notice some tranny fluid leaking. The fluid is still pink..no burnt smell or look to it. What do you think may have failed?

    Advertisement
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2 (permalink)  
Old 09-24-2002, 02:06 PM
roys63's Avatar
Member
 
Last photo:
Join Date: Dec 2001
Location: Nc
Age: 63
Posts: 907
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
Thumbs up

If this have high miles it may be the drive in the pump. this is driven by the converter. i have seen this may times with the PG and the TH350s allso trashes the converter or the converter trashes the pump?Well they just ware out together or the converter was not seated into the pump when installed...
Reply With Quote Quick reply to this message
  #3 (permalink)  
Old 09-29-2002, 10:06 PM
Registered User
 
Join Date: Sep 2002
Location: Riverdale, Georgia
Posts: 3
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
Talking

Thanks Roy63 for that answer...I've been away for a few days and have made a few inquiries and the answers that I've gotten definitely confirm what you said. I am in the process of getting in touch with a Transmission guy to get a fix on the cost. Thanks again. Matter of fact I will try to get back to you as soon as the diagnosis is in
Reply With Quote Quick reply to this message
  #4 (permalink)  
Old 10-01-2002, 06:03 PM
54 Chevy's Avatar
Member
 
Last photo:
Join Date: Feb 2002
Location: Belleville MI
Posts: 92
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
Post

I've got a Powerslide tranny left over from my 68' Camaro. It works great. Simply wanted to upgrade to a 700R4. I'm in the Detroit area if your interested.

Good Luck with the 69'
Reply With Quote Quick reply to this message
  #5 (permalink)  
Old 10-08-2002, 01:50 PM
Registered User
 
Join Date: Sep 2002
Location: Riverdale, Georgia
Posts: 3
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
Post

Thanks guys for the replies...It was a converter/pump problem and I had it rebuilt. The car is running just fine now. Thanks again for your input.
Reply With Quote Quick reply to this message

Recent Transmission - Rearend posts with photos

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -6. The time now is 12:49 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.