Priming Oil Pump SBC 350 - Hot Rod Forum : Hotrodders Bulletin Board
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Hotrodding Basics
User Name
Password
lost password?   |   register now

Reply
 
LinkBack Thread Tools
  #1 (permalink)  
Old 11-29-2011, 07:20 PM
Registered User
 
Last photo:
Join Date: Nov 2011
Location: ID
Posts: 17
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
Priming Oil Pump SBC 350

I just rebuilt my 350 motor, and when i am priming it oil only comes out on the drivers side head, and it only comes out of 5 of the rockers. It doesnt come out of any rockers on the other side. What could be the problem?

    Advertisement
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2 (permalink)  
Old 11-29-2011, 08:17 PM
SSedan64's Avatar
Registered User
 
Last photo:
Join Date: Dec 2007
Location: Macon, GA.
Age: 50
Posts: 6,016
Wiki Edits: 0

Thanks: 0
Thanked 46 Times in 46 Posts
What type Priming Tool are you using? If it doesn't have the 2 Lands at the bottom like the Distributor does, oil wont flow out to both sides of the Block, Heads.
Example Pics > http://www.google.com/search?hl=en&q...og&sa=N&tab=wi
Reply With Quote Quick reply to this message
  #3 (permalink)  
Old 11-30-2011, 07:02 AM
Richiehd's Avatar
JS-70
 
Last photo:
Join Date: Jun 2011
Location: Jupiter FL
Posts: 858
Wiki Edits: 0

Thanks: 174
Thanked 59 Times in 52 Posts
Quote:
Originally Posted by 29chev
I just rebuilt my 350 motor, and when i am priming it oil only comes out on the drivers side head, and it only comes out of 5 of the rockers. It doesnt come out of any rockers on the other side. What could be the problem?
You may also have to turn the motor over 1/4 turn at a time to fill all the oil galleries in addition to haveing the proper priming tool
Reply With Quote Quick reply to this message
  #4 (permalink)  
Old 12-01-2011, 07:51 PM
Registered User
 
Last photo:
Join Date: Nov 2011
Location: ID
Posts: 17
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
well i rented a priming tool from autozone, and now oil comes out all of the rockers when priming it. But when the motor is running oil doesnt come out of any of them.
Reply With Quote Quick reply to this message

Recent Hotrodding Basics posts with photos

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Oil Pump Priming Dino383 Engine 13 12-18-2010 11:05 PM
Priming oil pump DENCOUCH Engine 9 06-15-2008 08:21 AM
oil pump priming power Engine 8 06-21-2007 05:19 PM
Fuel Pump Not Priming Help!!!!!!!!!! 86camaro2.8l Engine 3 08-21-2006 10:56 AM
oil pump priming MardyMar Engine 1 05-03-2003 03:46 AM


All times are GMT -6. The time now is 04:33 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.