Problem FOUND ! Demon carb - Hot Rod Forum : Hotrodders Bulletin Board
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Engine
User Name
Password
lost password?   |   register now

Reply
 
LinkBack Thread Tools
  #1 (permalink)  
Old 08-17-2004, 08:15 AM
Beenaway2long's Avatar
or Jeff, or Doc, or...
 

Last journal entry: Results of the Camaro
Last photo:
Join Date: Nov 2003
Location: Syracuse, NY-well, just North
Age: 51
Posts: 988
Wiki Edits: 0

Thanks: 0
Thanked 4 Times in 3 Posts
Problem FOUND ! Demon carb

Some may know, I was having problems with my new motor for the last 4 months. I went from a Road Jr. to the Crate Demon when I found out from tech support that I HAD to use the Crate Demon. (Summit left me hanging there! Sold me the motor and carb at the same time, and wouldn't take the Raod jr back when I found it was the wrong one to use)
I threw a Crate Demon carb (Vacuum secondaries) on my 330hp/350 , and was driving myself NUTS for the last two months. Completely lost all faith in my tuning abilities (minimal , at best). The car would backfire intermittantly under hard acceleration. I took the thing apart NUMBEROUS times. Finally found the mother that was causing the problems. The rod that pushes the secondaries closed on deceleration, was slightly tweaked. When you floor it, it was dragging the secondaries open a little, and they would close right away. Never noticed it before. A little tweak to the rod, so it didn't bind, and we are backfire free !!!! This was driving me nuts! Also checked my Road Demon Jr., it did the same thing! NICE !! 2 NEW carbs, both with the exact same problem ! Wonder if I REALLY needed the Crate Demon???
Now, I can do some fine tuning, finally !

    Advertisement
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2 (permalink)  
Old 08-17-2004, 08:27 AM
figure8's Avatar
Member
 
Join Date: Nov 2002
Location: Des Moines, Iowa
Posts: 36
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
I don't see why the road Demon Jr. wouldn't have worked just fine. I have an Edelbrock 1406 600 cfm on my 330 hp 350 and it works fine out of the box. At the most the road demon jr. would require some very minor tuning. Why are these Carbs so limited to what they will work on when Edelbrock & Holly seem to work fine on just about any engine? Mabe someone can answer this question. Phil
Reply With Quote Quick reply to this message
  #3 (permalink)  
Old 08-17-2004, 09:41 AM
GoneNova/406's Avatar
Member
 
Join Date: Aug 2003
Location: columbus,ohio
Age: 58
Posts: 1,163
Wiki Edits: 0

Thanks: 0
Thanked 1 Time in 1 Post
there's a guy that lives two blocks from me that has a drag car falcon with a 460.his wife started working at jegs new wharehouse a couple of yrs. ago and when the demon carbs. first came out i remember him telling me that they had a lot of trouble with them.returns.from everything that i've been seeing in the car magazines though i just assumed they had gotten it all straightened out.thats good info to have cause i've been thinking about getting one in the future.
Reply With Quote Quick reply to this message
  #4 (permalink)  
Old 08-17-2004, 12:22 PM
Beenaway2long's Avatar
or Jeff, or Doc, or...
 

Last journal entry: Results of the Camaro
Last photo:
Join Date: Nov 2003
Location: Syracuse, NY-well, just North
Age: 51
Posts: 988
Wiki Edits: 0

Thanks: 0
Thanked 4 Times in 3 Posts
I was told that the reason the Road Jr wouldn't work, was because of the exhaust duration. You'd think that they would at least educate the sellers like Summit and Jegs. Or print a disclaimer of some sort. Either way, neither Summit and Grant would take the Jr back. Kind of sucks, because anything I run will have big duration. The CFM is more than plenty. Its the low signal strength that the duration produces will not allow the correct idle mixture.
Reply With Quote Quick reply to this message
  #5 (permalink)  
Old 08-17-2004, 01:06 PM
figure8's Avatar
Member
 
Join Date: Nov 2002
Location: Des Moines, Iowa
Posts: 36
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
now that you have figured out the problem have you ever considered trying the road demon jr. again. I bet you are right and it would work OK with the linkage fixed. Let us know what happens if you try it. Phil
Reply With Quote Quick reply to this message

Recent Engine posts with photos

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -6. The time now is 07:28 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.