Problem w/ TH350 - Hot Rod Forum : Hotrodders Bulletin Board
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Transmission - Rearend
User Name
Password
lost password?   |   register now

Reply
 
LinkBack Thread Tools
  #1 (permalink)  
Old 09-24-2002, 02:07 PM
New Member
 
Join Date: Sep 2002
Location: dallas, tx
Posts: 15
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
Question Problem w/ TH350

I just put a tci streetfighter converter in my car. 3000-3500 stall. The problem iam having is at higher rpms it feels like something is slipping. Like if i downshift to 2nd and floor it, at higher rpms it feels like something is sliping and the cars not as fast as it was before. The converter was new going in and it never did this before the swap. Does anybody have any ideas?

    Advertisement
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2 (permalink)  
Old 09-24-2002, 06:23 PM
Registered User
 
Join Date: Aug 2002
Location: SD
Posts: 6
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
Post

Whats the engine's specs?
Reply With Quote Quick reply to this message
  #3 (permalink)  
Old 09-24-2002, 06:51 PM
New Member
 
Join Date: Sep 2002
Location: dallas, tx
Posts: 15
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
Post

its a 350, about a .530 lift cam. Probably putting out around 420-430 to the flywheel.

What its doing kind of reminds me of when the clutch slips with a standard trans.
Reply With Quote Quick reply to this message
  #4 (permalink)  
Old 09-29-2002, 05:39 PM
Member
 
Last photo:
Join Date: Sep 2002
Location: USA
Posts: 490
Wiki Edits: 0

Thanks: 0
Thanked 2 Times in 2 Posts
Post

I would swap the converter out for a different one even a stock one to see if the problem is still there. If the problem goes away it's the converter, sounds like the stator is locked up.
Reply With Quote Quick reply to this message

Recent Transmission - Rearend posts with photos

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -6. The time now is 08:21 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.