problems caused by stupidity - Hot Rod Forum : Hotrodders Bulletin Board
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Engine
User Name
Password
lost password?   |   register now

Reply
 
LinkBack Thread Tools
  #1 (permalink)  
Old 11-06-2009, 07:09 PM
Registered User
 
Join Date: Oct 2009
Location: Clarksville, Mo
Posts: 84
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
problems caused by stupidity

replaced timing chain, put motor back together cranked on it to realize i had to have put it on wrong anyway tore it back down fixed it. started it to hear some rattling, thought rockers were loose so readjusted them, replaced valve covers. started the motor reved it a couple times then hear ome knocking, needles to say... pulled valve covers back off to find 10 bent push rods, 1 broke. should i even try to replace and restart or should i just pull heads? will my valves most likely be bent too?

    Advertisement
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2 (permalink)  
Old 11-06-2009, 08:26 PM
BOBCRMAN@aol.com's Avatar
Member
 
Last photo:
Join Date: May 2002
Location: Holly, michigan
Posts: 8,059
Wiki Edits: 0

Thanks: 20
Thanked 255 Times in 239 Posts
yes, just had the same thing happen to a customer with a BBC, he bent all the intake valves.
Reply With Quote Quick reply to this message
  #3 (permalink)  
Old 11-06-2009, 09:36 PM
66GMC's Avatar
Get in, sit down, hang on
 

Last journal entry: Cab Removal
Last photo:
Join Date: May 2005
Location: Olds, Alberta Canada
Age: 56
Posts: 2,761
Wiki Edits: 0

Thanks: 32
Thanked 90 Times in 85 Posts
Man that sucks.

On the up-side though ...
You've learned something, and it will likely be a mistake that you'll never repeat.

Don't be too hard on yourself.
Reply With Quote Quick reply to this message

Recent Engine posts with photos

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
383 stroker problems and ways to fix them leftoverchrisac Engine 15 02-06-2009 05:36 PM
Olds 98 Ignition Module Problems awbazar Electrical 1 01-12-2004 06:42 AM
beater car problems 02 0n 20s Engine 2 11-01-2003 06:53 PM
Light Problems like crazy ponybuster Electrical 7 10-14-2003 12:12 PM
LT1 knocking problems gollygwagen Engine 0 04-23-2003 05:52 AM


All times are GMT -6. The time now is 04:54 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.