Hot Rod Forum : Hotrodders Bulletin Board - View Single Post - problems with running my supercharged 351w
View Single Post
  #224 (permalink)  
Old 11-01-2013, 01:23 PM
mustang 671's Avatar
mustang 671 mustang 671 is offline
Registered User
 
Last photo:
Join Date: Oct 2010
Location: south england
Age: 37
Posts: 190
Wiki Edits: 0

Thanks: 51
Thanked 3 Times in 3 Posts
hi all.

finally got to the dyno last Tuesday for a initial set up . very strange though. seems my engine is flowing too well ?? with my pulley combo of bottom pulley 45 top pulley 51 it show's a underdriven value of 0.88 on holley chart which should be around 10-11 psi. however when on the dyno we crept up and it only produced 6.98 psi . at 6000 rpm first power run was 270 ish bhp , ignition changes and re jetting we got to 328 bhp . couldn't get anymore even with jetting up. just mader mix go higher but no more power. told the guys at the dyno what comp ratio I had with 7.48 - 1 and they said with mechanical loss I am only probably getting somewhere around 10.1 -1 , so they have said I need to get a smaller top pulley . or may be 2 . one to give me say 10 psi and another to say 14 psi so I can get it right in the same dyno session

any thoughts ? was very shocked that it only showed 6.98 psi with this combo , they said as I have -kb dished pistons. 30 thou over , mls gaskets and edelbrock victor jnr heads and large headers and exhaust pipes. and this new roller cam with higher lifts, it isn't even starting to produce power.

below is a video of a full throttle power run. torque at 378 and bhp at 328 and at flywheel was calculated as 392 bhp .



and another longer run to map ignition

Reply With Quote