Purolator oil filter substitution - Hot Rod Forum : Hotrodders Bulletin Board
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Engine
User Name
Password
lost password?   |   register now

Reply
 
LinkBack Thread Tools
  #1 (permalink)  
Old 08-19-2012, 08:51 AM
302 Z28's Avatar  
Last photo:
Join Date: May 2003
Location: North Texas
Posts: 10,837
Wiki Edits: 0

Thanks: 1
Thanked 86 Times in 73 Posts
Purolator oil filter substitution

Went to my local Pep Boys auto parts store yesterday to stock up on Purolator "PL" filters. I run Mobil 1 in all my vehicles and also run synthetic media filters. I quit using Mobil 1 filters when they got too expensive. I switched to the second highest rated filter for synthetic (from bobstheoilguy site) Purolatorís "PL" line. The listed PL filter for our 04 Tahoe is the PL14006 which is a short filter. When I got to Pep Boys they were out of the PL14006. I asked the counter guy if they had any more and he asked what it was for. I told him and he said "I have a better filter for that application". I expected him to come back with something other than a Purolator PL filter. He returned with a Purolator PL25288 which was twice as long as the recommended PL14006 for the same price. He said that is the one he uses on his 2005 Corvette and it will work on any LS based engine. He than quoted a web site that said the PL25288 filter will hold the equivalent of 31 paper clips in metal particles over the standard PL14006 filter. Just thought I would share for anyone with an LS based engine.

Vince

    Advertisement
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2 (permalink)  
Old 08-19-2012, 11:49 AM
bigdog7373's Avatar
Of course it's fast
 
Last photo:
Join Date: May 2010
Location: florida
Posts: 2,673
Wiki Edits: 0

Thanks: 13
Thanked 49 Times in 49 Posts
Why do you run synthetic? I had a tahoe with the 5.3 ls that i ran normal store brand 10w30 in. Sold it with 210k miles, no noises, smoke, or blow by at all. Only way i run systhetic is if the manufacturer says to.
Reply With Quote Quick reply to this message
  #3 (permalink)  
Old 08-19-2012, 12:39 PM
302 Z28's Avatar  
Last photo:
Join Date: May 2003
Location: North Texas
Posts: 10,837
Wiki Edits: 0

Thanks: 1
Thanked 86 Times in 73 Posts
Quote:
Originally Posted by bigdog7373 View Post
Why do you run synthetic? I had a tahoe with the 5.3 ls that i ran normal store brand 10w30 in. Sold it with 210k miles, no noises, smoke, or blow by at all. Only way i run systhetic is if the manufacturer says to.
It is pointless to explain why people run synthetic, it is obvious.

Vince
Reply With Quote Quick reply to this message

Recent Engine posts with photos

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Oil leak between oil filter adaptor plate and block HotRodMan Engine 3 04-23-2011 10:36 PM
Oil Filter Adapter for 93 camaro to delete oil cooler? tylerwerrin Engine 4 09-23-2010 11:15 AM
fram oil filter lower oil pressure elvis 66 chevelle Engine 33 09-14-2006 04:36 PM
Milodon oil pan...7 qt w/ filter or + filter? Finmike Engine 6 07-05-2004 10:44 PM
HV oil pump makes oil filter seal leak WBrianS Engine 13 11-20-2003 01:56 AM


All times are GMT -6. The time now is 06:37 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.